aboutsummaryrefslogtreecommitdiff
path: root/net/liferea
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-12-26 17:26:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-12-26 17:26:23 +0000
commit95cd43d1a7a37ab8b5c5d35edffd855ca36e32e3 (patch)
treec98c367d47f2b3badd56fedbd2a6218e517c0073 /net/liferea
parentc1f72f4d43acc2736d351706e1db0234be749d0c (diff)
downloadports-95cd43d1a7a37ab8b5c5d35edffd855ca36e32e3.tar.gz
ports-95cd43d1a7a37ab8b5c5d35edffd855ca36e32e3.zip
- Backport a vendor patch to respect HTTP proxy settings in HTML widget
PR: ports/163610 Submitted by: Fabian Keil <fk@fabiankeil.de>
Notes
Notes: svn path=/head/; revision=288060
Diffstat (limited to 'net/liferea')
-rw-r--r--net/liferea/Makefile1
-rw-r--r--net/liferea/files/patch-proxy-fix-137604645
2 files changed, 46 insertions, 0 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 6d1a207c2e2a..8ca27a90a017 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liferea
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= SF/${PORTNAME}/Liferea%20Stable/${PORTVERSION}
diff --git a/net/liferea/files/patch-proxy-fix-1376046 b/net/liferea/files/patch-proxy-fix-1376046
new file mode 100644
index 000000000000..e2b822b69371
--- /dev/null
+++ b/net/liferea/files/patch-proxy-fix-1376046
@@ -0,0 +1,45 @@
+From 137604683770cae900d5835befefd95c65866cd7 Mon Sep 17 00:00:00 2001
+From: Lars Lindner <lars.lindner@gmail.com>
+Date: Wed, 14 Dec 2011 18:18:02 +0100
+Subject: [PATCH] Fixes proxy preference not affecting the HTML widget.
+
+---
+ ChangeLog | 8 ++++++++
+ src/ui/liferea_htmlview.c | 5 +++++
+ 2 files changed, 13 insertions(+), 0 deletions(-)
+
+diff --git ChangeLog ChangeLog
+index 251bdb9..12724e5 100644
+--- ChangeLog
++++ ChangeLog
+@@ -1,3 +1,11 @@
++2011-12-?? ???
++
++ Version 1.8.1
++
++ * Fixes proxy preference not affecting the HTML widget.
++ (reported by Chris Siebenmann)
++
++
+ 2011-12-10 Lars Lindner <lars.lindner@gmail.com>
+
+ Version 1.8.0
+diff --git src/ui/liferea_htmlview.c src/ui/liferea_htmlview.c
+index 7642c3a..afb20f8 100644
+--- src/ui/liferea_htmlview.c
++++ src/ui/liferea_htmlview.c
+@@ -181,6 +181,11 @@ liferea_htmlview_new (gboolean forceInternalBrowsing)
+ g_signal_connect (network_monitor_get (), "proxy-changed",
+ G_CALLBACK (liferea_htmlview_proxy_changed),
+ htmlview);
++
++ if (NULL != network_get_proxy_host ()) {
++ debug0 (DEBUG_NET, "Setting initial HTML widget proxy...");
++ liferea_htmlview_proxy_changed (network_monitor_get (), htmlview);
++ }
+
+ return htmlview;
+ }
+--
+1.7.8
+