aboutsummaryrefslogtreecommitdiff
path: root/net/linknx/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-08 20:07:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-08 20:07:06 +0000
commitbcf2a6c47e12d8e8eac0490278d5d3a9d1d23301 (patch)
treea80d16c847d6517f86a988f43e1c34c9414bfbc8 /net/linknx/Makefile
parent9a9b537cdc95dd259ed23cbdae9850dc826b117f (diff)
downloadports-bcf2a6c47e12d8e8eac0490278d5d3a9d1d23301.tar.gz
ports-bcf2a6c47e12d8e8eac0490278d5d3a9d1d23301.zip
LinKNX is a backend for controlling a KNX/EIB home and building automation
system. It connects to eibd which is part of the BCU SDK and keeps state of KNX devices such as lamps, window blinds, heating and so on. Furthermore it provides a powerful, rule-based event after treatment, e.g. for switching other KNX devices, sending e-mail or SMS or executing a shell command. You can configure and control the LinKNX daemon using an XML-style protocol via TCP network socket or Unix domain socket. WWW: http://linknx.sourceforge.net/ PR: ports/128320 Submitted by: Björn König <bkoenig at alpha-tierchen.de>
Notes
Notes: svn path=/head/; revision=222557
Diffstat (limited to 'net/linknx/Makefile')
-rw-r--r--net/linknx/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
new file mode 100644
index 000000000000..d58897ac3650
--- /dev/null
+++ b/net/linknx/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: linknx
+# Date Created: 23 October 2008
+# Whom: Björn König <bkoenig@alpha-tierchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linknx
+PORTVERSION= 0.0.1.25
+CATEGORIES= net
+MASTER_SITES= SF
+
+MAINTAINER= bkoenig@alpha-tierchen.de
+COMMENT= Rule-based event handling in a KNX installation
+
+LIB_DEPENDS= pthsem.20:${PORTSDIR}/devel/pthsem
+BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
+
+OPTIONS= LIBESMTP "Install libesmtp for SMTP support" on \
+ LIBCURL "Install libcurl for Clickatell SMS support" off
+
+.include <bsd.port.pre.mk>
+
+.if (defined(WITH_LIBESMTP) || exists(${LOCALBASE}/include/libesmtp.h))
+CONFIGURE+= --enable-smtp
+LIB_DEPENDS+= esmtp.6:${PORTSDIR}/mail/libesmtp
+.endif
+
+.if (defined(WITH_LIBCURL) || exists(${LOCALBASE}/lib/libcurl.so))
+LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+.endif
+
+USE_RC_SUBR= ${PORTNAME}
+
+.include <bsd.port.post.mk>