aboutsummaryrefslogtreecommitdiff
path: root/net/linux-f10-nss_ldap/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2012-01-20 21:25:59 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2012-01-20 21:25:59 +0000
commit1f2f33896628ea2e47e2fc49c769edb25e8900dd (patch)
tree32625d8b56255a48f8345be146dfc8bb2c589e9f /net/linux-f10-nss_ldap/Makefile
parent64bfbd5ee2dcc83afbad11cbd40faff315144916 (diff)
downloadports-1f2f33896628ea2e47e2fc49c769edb25e8900dd.tar.gz
ports-1f2f33896628ea2e47e2fc49c769edb25e8900dd.zip
This a port of the nss_ldap libraries for linux.
You'll probably need this if your system users in a LDAP directory are complaining their linux programs won't run, and errors on the console say "getpwuid_r(): failed due to unknown user id". PR: ports/164113 Submitted by: rskinner port_maintainer@herveybayaustralia.com.au Minor modifications (no license install, srpm checksum) by: netchild Note: the license framework does not seem to DTRT with linux ports
Notes
Notes: svn path=/head/; revision=289547
Diffstat (limited to 'net/linux-f10-nss_ldap/Makefile')
-rw-r--r--net/linux-f10-nss_ldap/Makefile78
1 files changed, 78 insertions, 0 deletions
diff --git a/net/linux-f10-nss_ldap/Makefile b/net/linux-f10-nss_ldap/Makefile
new file mode 100644
index 000000000000..9d6626aa4f68
--- /dev/null
+++ b/net/linux-f10-nss_ldap/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: linux-f10-nss_ldap
+# Date created: 2012-01-04
+# Whom: rskinner port_maintainer@herveybayaustralia.com.au
+#
+# $FreeBSD$
+#
+
+PORTNAME= nss_ldap
+PORTVERSION= ${NSS_LDAP_VERSION}
+CATEGORIES= net linux
+MASTER_SITES= ftp://ftp.pbone.net/mirror/archive.fedoraproject.org/fedora/linux/updates/testing/10/i386/ \
+ http://archives.fedoraproject.org/pub/archive/fedora/linux/updates/testing/10/i386/ \
+ http://herveybayaustralia.com.au/ports/distfiles/
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}-${RPMVERSION}
+
+MAINTAINER= port_maintainer@herveybayaustralia.com.au
+COMMENT= RFC 2307 NSS Module (Linux Fedora 10)
+
+LICENSE= GPLv2
+NO_LICENSES_INSTALL=yes # license framework does not rm the "share" directory
+
+NSS_LDAP_VERSION=264
+
+USE_LINUX_RPM= yes
+USE_LINUX_PREFIX=yes
+LINUX_DIST_VER= 10
+RPMVERSION= 6.fc10
+USE_LDCONFIG= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${NSS_LDAP_VERSION}
+
+MANPREFIX= ${PREFIX}/usr/share
+MANCOMPRESSED= no
+MAN5= nss_ldap.5.gz
+
+.if defined(WITH_PAM)
+PLIST_SUB+= PAM=""
+MAN5+= pam_ldap.5.gz
+.else
+PLIST_SUB+= PAM="@comment "
+.endif
+
+PORTDOCS=*
+
+pre-fetch:
+.if !defined(WITH_PAM)
+ @${ECHO_MSG} "Use WITH_PAM if you require more advanced ldap support in the linuxulator"
+.endif
+
+post-extract:
+ @if [ -f ${WRKDIR}/etc/ldap.conf ]; then \
+ ${MV} ${WRKDIR}/etc/ldap.conf ${WRKDIR}/etc/ldap.conf.dist; \
+ fi
+.if !defined(WITH_PAM)
+ @if [ -f ${WRKDIR}/lib/security/pam_ldap.so ]; then \
+ ${RM} -rf ${WRKDIR}/lib/; \
+ fi
+ @if [ -f ${WRKDIR}/usr/share/doc/nss_ldap-264/COPYING.pam_ldap ]; then \
+ ${RM} ${WRKDIR}/usr/share/doc/nss_ldap-264/*.pam*; \
+ ${RM} -rf ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d; \
+ fi
+ @if [ -f ${WRKDIR}/usr/share/man/man5/pam_ldap.5.gz ]; then \
+ ${RM} ${WRKDIR}/usr/share/man/man5/pam_ldap.5.gz; \
+ fi
+.else
+.if defined(NOPORTDOCS)
+ @if [ -d ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d ]; then \
+ ${RM} -rf ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d/; \
+ fi
+.endif
+.endif
+
+post-install:
+ @${RM} ${PREFIX}/GPLv2 # somehow installed by LICENSE framework
+ @${CAT} ${PKGMESSAGE};
+
+.include <bsd.port.mk>