aboutsummaryrefslogtreecommitdiff
path: root/net/mDNSResponder
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2005-03-25 17:24:13 +0000
committerBrooks Davis <brooks@FreeBSD.org>2005-03-25 17:24:13 +0000
commit97058ab04a7754fa990bd22ad192c19237a20268 (patch)
tree9bdf85af21ae33ef5d5b89976ad81b7946511c62 /net/mDNSResponder
parent782b0f896bdf033daabbf3b1f8f30934a91fc304 (diff)
downloadports-97058ab04a7754fa990bd22ad192c19237a20268.tar.gz
ports-97058ab04a7754fa990bd22ad192c19237a20268.zip
Switch mDNSResponder from the Apple startup script to a simple rc.subr
script. This means that mdnsd is not started by default and must be enabled by adding an mdnsd_enable="YES" line to your /etc/rc.conf. This works around a panic in the multicast code when network interfaces are removed and multicast sockets are open on them since many users of this port only need the utilities, not the daemon. Approved by: portmgr (krion)
Notes
Notes: svn path=/head/; revision=131950
Diffstat (limited to 'net/mDNSResponder')
-rw-r--r--net/mDNSResponder/Makefile2
-rw-r--r--net/mDNSResponder/files/mdnsd.sh.in19
-rw-r--r--net/mDNSResponder/files/patch-mDNSPosix_Makefile14
-rw-r--r--net/mDNSResponder/pkg-plist1
4 files changed, 35 insertions, 1 deletions
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index 9d473e0046bc..79d64221bc51 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mDNSResponder
PORTVERSION= 98
+PORTREVISION= 1
CATEGORIES= net dns
MASTER_SITES= http://darwinsource.opendarwin.org/tarballs/apsl/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -19,6 +20,7 @@ INSTALLS_SHLIB= YES
USE_GMAKE= YES
USE_REINPLACE= YES
+USE_RC_SUBR= mdnsd.sh
MAKE_ARGS+= os=freebsd LOCALBASE=${PREFIX} MANPATH=${MANPREFIX}/man
BUILD_WRKSRC= ${WRKSRC}/mDNSPosix
INSTALL_WRKSRC= ${WRKSRC}/mDNSPosix
diff --git a/net/mDNSResponder/files/mdnsd.sh.in b/net/mDNSResponder/files/mdnsd.sh.in
new file mode 100644
index 000000000000..cd245d6225fb
--- /dev/null
+++ b/net/mDNSResponder/files/mdnsd.sh.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: mdnsd
+# REQIORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+mdnsd_enable="NO"
+
+. %%RC_SUBR%%
+
+name=mdnsd
+rc_var=`set_rcvar`
+command="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config $name
+
+run_rc_command $*
diff --git a/net/mDNSResponder/files/patch-mDNSPosix_Makefile b/net/mDNSResponder/files/patch-mDNSPosix_Makefile
new file mode 100644
index 000000000000..3cda77d917a2
--- /dev/null
+++ b/net/mDNSResponder/files/patch-mDNSPosix_Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- mDNSPosix/Makefile.orig
++++ mDNSPosix/Makefile
+@@ -369,7 +369,7 @@
+
+ all: setup Daemon libdns_sd Client Responder ProxyResponder Identify NetMonitor dnsextd $(OPTIONALTARG)
+
+-install: setup InstalledDaemon InstalledLib InstalledStartup InstalledManPages $(OPTINSTALL)
++install: setup InstalledDaemon InstalledLib InstalledManPages $(OPTINSTALL)
+
+ # 'setup' sets up the build directory structure the way we want
+ setup:
diff --git a/net/mDNSResponder/pkg-plist b/net/mDNSResponder/pkg-plist
index b4c8ee542a49..1dc49f5642a9 100644
--- a/net/mDNSResponder/pkg-plist
+++ b/net/mDNSResponder/pkg-plist
@@ -3,7 +3,6 @@ bin/mDNSIdentify
bin/mDNSNetMonitor
bin/mDNSProxyResponderPosix
bin/mDNSResponderPosix
-etc/rc.d/mdns.sh
include/dns_sd.h
lib/libdns_sd.so
lib/libdns_sd.so.1