aboutsummaryrefslogtreecommitdiff
path: root/net/messagelib
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-07 12:54:22 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-07 12:59:12 +0000
commit09f5a2edb26a7d6afd3b62a078a558a3c1786a29 (patch)
treed86598a26fa44b182d8e587dc84a18defbcfba7d /net/messagelib
parent158944b89e6532daf6e1c9d6b635694273a8685d (diff)
downloadports-09f5a2edb26a7d6afd3b62a078a558a3c1786a29.tar.gz
ports-09f5a2edb26a7d6afd3b62a078a558a3c1786a29.zip
*: (KDE PIM) Reduce dependencies
- Boost is a build-dep for all of these ports, using header-only libraries; there **are** library-uses of Boost in KDE PIM, just not here. - ECM is a build-dep that is not needed at runtime. - Qt testlib is a build-dep.
Diffstat (limited to 'net/messagelib')
-rw-r--r--net/messagelib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/messagelib/Makefile b/net/messagelib/Makefile
index 4b4ea137b4b0..bf8fd565457e 100644
--- a/net/messagelib/Makefile
+++ b/net/messagelib/Makefile
@@ -1,5 +1,6 @@
PORTNAME= messagelib
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,8 +11,8 @@ LICENSE= LGPL21
DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
EXPIRATION_DATE=2021-06-23
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
LIB_DEPENDS= libassuan.so:security/libassuan \
- libboost_system.so:devel/boost-libs \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
@@ -19,17 +20,18 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 qca qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
- coreaddons ecm i18n iconthemes imap itemmodels itemviews jobwidgets \
+ coreaddons i18n iconthemes imap itemmodels itemviews jobwidgets \
kdewebkit kio service solid sonnet syntaxhighlighting \
- textwidgets wallet widgetsaddons windowsystem xmlgui
+ textwidgets wallet widgetsaddons windowsystem xmlgui \
+ ecm_build
# pim components
USE_KDE+= akonadi akonadicontacts akonadimime akonadisearch calendarcore \
contacts grantleetheme gravatar identitymanagement \
ldap libkdepim libkleo mailtransport mbox \
mime pimcommon pimtextedit
-USE_QT= concurrent core dbus declarative gui location network printsupport testlib \
+USE_QT= concurrent core dbus declarative gui location network printsupport \
uitools webchannel webengine widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes