aboutsummaryrefslogtreecommitdiff
path: root/net/morebalance
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-11 18:48:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-11 18:48:28 +0000
commitaa50c50a7f85d052a1768331ab6c99dea627841d (patch)
tree3f71b09236aee0be8ed3f04ac71d7a00d740806e /net/morebalance
parent3777ea8a6b96078dc255191a283c921d7f10988d (diff)
downloadports-aa50c50a7f85d052a1768331ab6c99dea627841d.tar.gz
ports-aa50c50a7f85d052a1768331ab6c99dea627841d.zip
Add morebalance 0.2, a modular open source user-space load
balancing system. PR: 57868 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Notes
Notes: svn path=/head/; revision=90859
Diffstat (limited to 'net/morebalance')
-rw-r--r--net/morebalance/Makefile43
-rw-r--r--net/morebalance/distinfo1
-rw-r--r--net/morebalance/files/patch-Makefile34
-rw-r--r--net/morebalance/files/patch-sys.c10
-rw-r--r--net/morebalance/pkg-descr4
-rw-r--r--net/morebalance/pkg-plist2
6 files changed, 94 insertions, 0 deletions
diff --git a/net/morebalance/Makefile b/net/morebalance/Makefile
new file mode 100644
index 000000000000..2c2079ebc1f5
--- /dev/null
+++ b/net/morebalance/Makefile
@@ -0,0 +1,43 @@
+# New ports collection Makefile for: morebalance
+# Date created: Wed Oct 8
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= morebalance
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://mindx.dyndns.org/morebalance/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= A modular open source user-space load balancing system
+
+USE_REINPLACE= yes
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+USE_GETOPT_LONG= yes
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CFLAGS+= -DUSE_PCRE
+LDFLAGS+= -L${LOCALBASE}/lib -lpcre
+.endif
+
+.if defined(WITH_TLS)
+LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls \
+ ggz.1:${PORTSDIR}/games/libggz
+CFLAGS+= -DUSE_TLS
+LDFLAGS+= -lggz -lgnutls -L${LOCALBASE}/lib
+.endif
+
+MAN1= morebalance.1
+MAN5= morebalance.conf.5
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.conf.5 ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/net/morebalance/distinfo b/net/morebalance/distinfo
new file mode 100644
index 000000000000..474449f9e44b
--- /dev/null
+++ b/net/morebalance/distinfo
@@ -0,0 +1 @@
+MD5 (morebalance-0.2.tar.gz) = 2b917d789dcc620abe68df295d91fec7
diff --git a/net/morebalance/files/patch-Makefile b/net/morebalance/files/patch-Makefile
new file mode 100644
index 000000000000..d1113ed77130
--- /dev/null
+++ b/net/morebalance/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile.orig Wed Oct 8 13:54:08 2003
++++ Makefile Sat Oct 11 15:38:37 2003
+@@ -1,26 +1,21 @@
+ VERSION = 0.2
+-#PCRE=-lpcre
+-#GNUTLS=-lggz -lgnutls
+-
+-CC = gcc
+-CFLAGS = -Wall -O3 -ggdb3
+
+ OBJECTS = main.o conf.o sys.o magic.o server.o ipban.o filter.o
+
+ all: morebalance
+
+ morebalance: $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) -lpthread $(PCRE) $(GNUTLS)
++ $(CC) $(CFLAGS) -o $@ $(OBJECTS) $(LDFLAGS)
+
+ clean:
+ rm -f *.o
+ rm -f morebalance
+
+ install: morebalance
+- install -d -m755 $(DESTDIR)$(prefix)/usr/bin
+- install -d -m755 $(DESTDIR)$(prefix)/etc
+- cp morebalance $(DESTDIR)$(prefix)/usr/bin
+- cp morebalance.conf $(DESTDIR)$(prefix)/etc
++ install -d -m755 $(DESTDIR)$(PREFIX)/bin
++ install -d -m755 $(DESTDIR)$(PREFIX)/etc
++ cp morebalance $(DESTDIR)$(PREFIX)/bin
++ cp morebalance.conf $(DESTDIR)$(PREFIX)/etc
+
+ distclean: clean
+ rm -f configure-stamp
diff --git a/net/morebalance/files/patch-sys.c b/net/morebalance/files/patch-sys.c
new file mode 100644
index 000000000000..603abfa92a89
--- /dev/null
+++ b/net/morebalance/files/patch-sys.c
@@ -0,0 +1,10 @@
+--- sys.c.orig Sat Oct 11 20:37:45 2003
++++ sys.c Sat Oct 11 20:38:00 2003
+@@ -2,6 +2,7 @@
+ #include "sys.h"
+
+ /* System includes */
++#include <sys/types.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <stdlib.h>
diff --git a/net/morebalance/pkg-descr b/net/morebalance/pkg-descr
new file mode 100644
index 000000000000..0133a85808d0
--- /dev/null
+++ b/net/morebalance/pkg-descr
@@ -0,0 +1,4 @@
+MoreBalance is a modular open source user-space load balancing system.
+It also serves as a general fun networking tool.
+
+WWW: http://mindx.dyndns.org/morebalance/
diff --git a/net/morebalance/pkg-plist b/net/morebalance/pkg-plist
new file mode 100644
index 000000000000..3534fe8203a7
--- /dev/null
+++ b/net/morebalance/pkg-plist
@@ -0,0 +1,2 @@
+sbin/morebalance
+etc/morebalance.conf.sample