aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-09-02 22:28:43 +0000
committerSteve Wills <swills@FreeBSD.org>2019-09-02 22:28:43 +0000
commit6435715f162202bf1087194884a7fbbd61429abd (patch)
treea73b1fa066b9e4de27d3e2771f2685c99ce09799 /net/mosquitto
parent43e75d76cc192b746eb55836fc4ecaa9d8ded0df (diff)
downloadports-6435715f162202bf1087194884a7fbbd61429abd.tar.gz
ports-6435715f162202bf1087194884a7fbbd61429abd.zip
net/mosquitto: update to 1.6.4
PR: 239675 Submitted by: joe@thrallingpenguin.com (maintainer) Reported by: crest@rlwinm.de
Notes
Notes: svn path=/head/; revision=510858
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile2
-rw-r--r--net/mosquitto/distinfo6
-rw-r--r--net/mosquitto/files/patch-CMakeLists.txt32
-rw-r--r--net/mosquitto/files/patch-config.mk6
-rw-r--r--net/mosquitto/files/patch-lib_mosquitto__internal.h33
-rw-r--r--net/mosquitto/files/patch-mosquitto.conf28
-rw-r--r--net/mosquitto/files/patch-src_CMakeLists.txt20
-rw-r--r--net/mosquitto/files/patch-src_mosquitto__passwd.c8
-rw-r--r--net/mosquitto/pkg-plist2
9 files changed, 54 insertions, 83 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 7a440f5eff03..8411ee7c0560 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mosquitto
-PORTVERSION= 1.5.8
+PORTVERSION= 1.6.4
CATEGORIES= net
MASTER_SITES= http://mosquitto.org/files/source/
diff --git a/net/mosquitto/distinfo b/net/mosquitto/distinfo
index fda2e31c2c3a..cf69915cb166 100644
--- a/net/mosquitto/distinfo
+++ b/net/mosquitto/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551386128
-SHA256 (mosquitto-1.5.8.tar.gz) = 78d7e70c3794dc3a1d484b4f2f8d3addebe9c2da3f5a1cebe557f7d13beb0da4
-SIZE (mosquitto-1.5.8.tar.gz) = 442834
+TIMESTAMP = 1565197492
+SHA256 (mosquitto-1.6.4.tar.gz) = a3d5822c249f6a6e13311b1b09eff6807ea01608a5a77934e1769842e9d146ef
+SIZE (mosquitto-1.6.4.tar.gz) = 576040
diff --git a/net/mosquitto/files/patch-CMakeLists.txt b/net/mosquitto/files/patch-CMakeLists.txt
index 97410d3bd6d7..41c78c64a988 100644
--- a/net/mosquitto/files/patch-CMakeLists.txt
+++ b/net/mosquitto/files/patch-CMakeLists.txt
@@ -1,6 +1,8 @@
---- CMakeLists.txt.orig 2018-09-25 15:27:43 UTC
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt.orig
+++ CMakeLists.txt
-@@ -15,6 +15,9 @@ set (VERSION 1.5.3)
+@@ -15,6 +15,9 @@ set (VERSION 1.6.4)
add_definitions (-DCMAKE -DVERSION=\"${VERSION}\")
@@ -8,17 +10,17 @@
+link_directories(/usr/local/lib)
+
if (WIN32)
- set (BINDIR .)
- set (SBINDIR .)
-@@ -40,9 +43,9 @@ else (WIN32)
- set (CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${LIBDIR}")
- set (INCLUDEDIR include)
- set (DATAROOTDIR share)
-- set (MANDIR "${DATAROOTDIR}/man")
-+ set (MANDIR "man")
- set (SHAREDIR "${DATAROOTDIR}/mosquitto")
-- set (PKGCONFIGDIR "${LIBDIR}/pkgconfig")
-+ set (PKGCONFIGDIR "${CMAKE_LIBDATADIR}/pkgconfig")
- endif (WIN32)
+ add_definitions("-D_CRT_SECURE_NO_WARNINGS")
+ add_definitions("-D_CRT_NONSTDC_NO_DEPRECATE")
+@@ -108,9 +111,9 @@ install(FILES mosquitto.conf aclfile.exa
+ # ========================================
- option(WITH_TLS
+ configure_file(libmosquitto.pc.in libmosquitto.pc @ONLY)
+-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libmosquitto.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/share/pkgconfig")
++install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libmosquitto.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig")
+ configure_file(libmosquittopp.pc.in libmosquittopp.pc @ONLY)
+-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libmosquittopp.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/share/pkgconfig")
++install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libmosquittopp.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig")
+
+ # ========================================
+ # Testing
diff --git a/net/mosquitto/files/patch-config.mk b/net/mosquitto/files/patch-config.mk
index 3b227dbe2f18..d4043a0b346d 100644
--- a/net/mosquitto/files/patch-config.mk
+++ b/net/mosquitto/files/patch-config.mk
@@ -1,6 +1,8 @@
---- config.mk.orig 2018-09-25 15:27:43 UTC
+Index: config.mk
+===================================================================
+--- config.mk.orig
+++ config.mk
-@@ -275,7 +275,7 @@ ifeq ($(WITH_WEBSOCKETS),static)
+@@ -283,7 +283,7 @@ ifeq ($(WITH_WEBSOCKETS),static)
endif
INSTALL?=install
diff --git a/net/mosquitto/files/patch-lib_mosquitto__internal.h b/net/mosquitto/files/patch-lib_mosquitto__internal.h
deleted file mode 100644
index 8f16e3f0f968..000000000000
--- a/net/mosquitto/files/patch-lib_mosquitto__internal.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- lib/mosquitto_internal.h.orig 2018-09-25 15:27:43 UTC
-+++ lib/mosquitto_internal.h
-@@ -31,11 +31,7 @@ Contributors:
- #endif
- #include <stdlib.h>
-
--#if defined(WITH_THREADING) && !defined(WITH_BROKER)
--# include <pthread.h>
--#else
--# include <dummypthread.h>
--#endif
-+#include <pthread.h>
-
- #ifdef WITH_SRV
- # include <ares.h>
-@@ -194,7 +190,7 @@ struct mosquitto {
- #endif
- bool want_write;
- bool want_connect;
--#if defined(WITH_THREADING) && !defined(WITH_BROKER)
-+
- pthread_mutex_t callback_mutex;
- pthread_mutex_t log_callback_mutex;
- pthread_mutex_t msgtime_mutex;
-@@ -205,7 +201,7 @@ struct mosquitto {
- pthread_mutex_t out_message_mutex;
- pthread_mutex_t mid_mutex;
- pthread_t thread_id;
--#endif
-+
- bool clean_session;
- #ifdef WITH_BROKER
- char *old_id; /* for when a duplicate client connects, but we still want to
diff --git a/net/mosquitto/files/patch-mosquitto.conf b/net/mosquitto/files/patch-mosquitto.conf
index e31c8f984559..022827c27b20 100644
--- a/net/mosquitto/files/patch-mosquitto.conf
+++ b/net/mosquitto/files/patch-mosquitto.conf
@@ -1,33 +1,35 @@
---- mosquitto.conf.orig 2019-02-06 15:54:59 UTC
+Index: mosquitto.conf
+===================================================================
+--- mosquitto.conf.orig
+++ mosquitto.conf
-@@ -28,7 +28,7 @@
+@@ -158,7 +158,7 @@
# This should be set to /var/run/mosquitto.pid if mosquitto is
- # being run automatically on boot with an init script and
+ # being run automatically on boot with an init script and
# start-stop-daemon or similar.
-#pid_file
+pid_file /var/run/mosquitto.pid
- # When run as root, drop privileges to this user and its primary
- # group.
-@@ -36,7 +36,7 @@
+ # Set to true to queue messages with QoS 0 when a persistent client is
+ # disconnected. These messages are included in the limit imposed by
+@@ -195,7 +195,7 @@
# If run as a non-root user, this setting has no effect.
- # Note that on Windows this has no effect and so mosquitto should
+ # Note that on Windows this has no effect and so mosquitto should
# be started by the user you wish it to run as.
-#user mosquitto
+user nobody
- # The maximum number of QoS 1 and 2 messages currently inflight per
- # client.
-@@ -173,7 +173,7 @@
+ # =================================================================
+ # Default listener
+@@ -208,7 +208,7 @@
#bind_address
# Port to use for the default listener.
-#port 1883
+port 1883
- # The maximum number of client connections to allow. This is
- # a per listener setting.
-@@ -224,7 +224,7 @@
+ # Bind the listener to a specific interface. This is similar to
+ # bind_address above but is useful when an interface has multiple addresses or
+@@ -267,7 +267,7 @@
# containing the CA certificates. For capath to work correctly, the
# certificate files must have ".crt" as the file ending and you must run
# "openssl rehash <path to capath>" each time you add/remove a certificate.
diff --git a/net/mosquitto/files/patch-src_CMakeLists.txt b/net/mosquitto/files/patch-src_CMakeLists.txt
index 90bb0e36d2e1..5ee92aeb7bc9 100644
--- a/net/mosquitto/files/patch-src_CMakeLists.txt
+++ b/net/mosquitto/files/patch-src_CMakeLists.txt
@@ -1,14 +1,16 @@
---- src/CMakeLists.txt.orig 2018-09-25 15:27:43 UTC
+Index: src/CMakeLists.txt
+===================================================================
+--- src/CMakeLists.txt.orig
+++ src/CMakeLists.txt
-@@ -114,6 +114,7 @@
+@@ -126,6 +126,7 @@ if (WIN32 OR CYGWIN)
endif (WIN32 OR CYGWIN)
add_definitions (-DWITH_BROKER)
+add_definitions (-DWITH_THREADING)
- set (MOSQ_LIBS ${MOSQ_LIBS} ${OPENSSL_LIBRARIES})
-
-@@ -132,7 +133,7 @@
+ if (WITH_DLT)
+ message(STATUS "DLT_LIBDIR = ${DLT_LIBDIR}")
+@@ -149,7 +150,7 @@ if (UNIX)
elseif(QNX)
set(MOSQ_LIBS ${MOSQ_LIBS} m socket)
else(APPLE)
@@ -17,11 +19,3 @@
find_library(LIBRT rt)
if (LIBRT)
set (MOSQ_LIBS ${MOSQ_LIBS} rt)
-@@ -186,7 +187,6 @@
- endif (${WITH_TLS} STREQUAL ON)
-
- if (UNIX AND NOT APPLE)
-- install(CODE "EXEC_PROGRAM(/sbin/ldconfig)")
- endif (UNIX AND NOT APPLE)
-
-
diff --git a/net/mosquitto/files/patch-src_mosquitto__passwd.c b/net/mosquitto/files/patch-src_mosquitto__passwd.c
index 9dd0659dd751..d8ec244efcb4 100644
--- a/net/mosquitto/files/patch-src_mosquitto__passwd.c
+++ b/net/mosquitto/files/patch-src_mosquitto__passwd.c
@@ -1,6 +1,8 @@
---- src/mosquitto_passwd.c.orig 2019-02-28 17:18:59 UTC
+Index: src/mosquitto_passwd.c
+===================================================================
+--- src/mosquitto_passwd.c.orig
+++ src/mosquitto_passwd.c
-@@ -100,7 +100,7 @@ int output_new_password(FILE *fptr, const char *userna
+@@ -141,7 +141,7 @@ int output_new_password(FILE *fptr, cons
unsigned char hash[EVP_MAX_MD_SIZE];
unsigned int hash_len;
const EVP_MD *digest;
@@ -9,7 +11,7 @@
EVP_MD_CTX context;
#else
EVP_MD_CTX *context;
-@@ -127,7 +127,7 @@ int output_new_password(FILE *fptr, const char *userna
+@@ -168,7 +168,7 @@ int output_new_password(FILE *fptr, cons
return 1;
}
diff --git a/net/mosquitto/pkg-plist b/net/mosquitto/pkg-plist
index efc52e94f09b..eab3cbeae2cc 100644
--- a/net/mosquitto/pkg-plist
+++ b/net/mosquitto/pkg-plist
@@ -1,6 +1,7 @@
bin/mosquitto_passwd
bin/mosquitto_pub
bin/mosquitto_sub
+bin/mosquitto_rr
@sample %%ETCDIR%%/aclfile.sample
@sample %%ETCDIR%%/mosquitto.conf.sample
@sample %%ETCDIR%%/pskfile.sample
@@ -19,6 +20,7 @@ libdata/pkgconfig/libmosquitto.pc
libdata/pkgconfig/libmosquittopp.pc
man/man1/mosquitto_passwd.1.gz
man/man1/mosquitto_pub.1.gz
+man/man1/mosquitto_rr.1.gz
man/man1/mosquitto_sub.1.gz
man/man3/libmosquitto.3.gz
man/man5/mosquitto.conf.5.gz