aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2015-07-04 09:14:06 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2015-07-04 09:14:06 +0000
commit7f7d823800fd8b8c27d48866d324514543aa8c68 (patch)
tree89fbc9170c7ab45b948aa61113eb31f5e3f89d65 /net/mosquitto
parent4c1ddf0f0482f4dad3b54ab7be8a6e1c2b604924 (diff)
downloadports-7f7d823800fd8b8c27d48866d324514543aa8c68.tar.gz
ports-7f7d823800fd8b8c27d48866d324514543aa8c68.zip
- update to 1.4.2
The Python driver is now provided by net/py-paho-mqtt! More drivers can be found at http://eclipse.org/paho PR: 200540 Submitted by: ohauer Approved by: Joseph Benden <joe@thrallingpenguin.com> (maintainer, via PM)
Notes
Notes: svn path=/head/; revision=391297
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/Makefile21
-rw-r--r--net/mosquitto/distinfo4
-rw-r--r--net/mosquitto/files/patch-CMakeLists.txt10
-rw-r--r--net/mosquitto/files/patch-config.mk6
-rw-r--r--net/mosquitto/files/patch-lib_tls__mosq.h4
-rw-r--r--net/mosquitto/files/patch-mosquitto.conf2
-rw-r--r--net/mosquitto/files/patch-src_CMakeLists.txt6
-rw-r--r--net/mosquitto/pkg-descr8
-rw-r--r--net/mosquitto/pkg-message1
-rw-r--r--net/mosquitto/pkg-plist3
10 files changed, 25 insertions, 40 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 3fc1483d66ee..a32dc2ff5351 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mosquitto
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.4.2
CATEGORIES= net
MASTER_SITES= http://mosquitto.org/files/source/
@@ -15,36 +14,20 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:${PORTSDIR}/dns/c-ares
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-OPTIONS_DEFAULT=PYTHON
-OPTIONS_DEFINE= PYTHON
-
-PYTHON_DESC= Build python driver
-
USES= cmake python:2
NOCONFIGURE= yes
USE_RC_SUBR= mosquitto
USE_LDCONFIG= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION}
USERS= nobody
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-PLIST_SUB= PYTHON_VER=${PYTHON_VER} NOPYTHON="" PORTVERSION=${PORTVERSION}
-.else
-PLIST_SUB= NOPYTHON="@comment " PORTVERSION=${PORTVERSION}
-.endif
-
post-patch:
# do not run ldconfig in stage dir
${REINPLACE_CMD} -e '/ldconfig/d' ${WRKSRC}/src/CMakeLists.txt \
${WRKSRC}/lib/CMakeLists.txt ${WRKSRC}/lib/cpp/CMakeLists.txt
post-stage:
-.if ${PORT_OPTIONS:MPYTHON}
- (cd ${WRKSRC}/lib/python && \
- ${PYTHON_CMD} ${WRKSRC}/lib/python/setup.py build install --prefix=${PREFIX} --root=${STAGEDIR})
-.endif
# Adjust configuration files
${MV} ${STAGEDIR}${ETCDIR}/mosquitto.conf ${STAGEDIR}${ETCDIR}/mosquitto.conf.sample
${MV} ${STAGEDIR}${ETCDIR}/pwfile.example ${STAGEDIR}${ETCDIR}/pwfile.sample
diff --git a/net/mosquitto/distinfo b/net/mosquitto/distinfo
index 0ce16a44b26b..9ef4c072aa83 100644
--- a/net/mosquitto/distinfo
+++ b/net/mosquitto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mosquitto-1.3.5.tar.gz) = 16eb3dbef183827665feee9288362c7352cd016ba04ca0402a0ccf857d1c2ab2
-SIZE (mosquitto-1.3.5.tar.gz) = 352231
+SHA256 (mosquitto-1.4.2.tar.gz) = 5ebc3800a0018bfbec62dcc3748fb29f628df068acd39c62c4ef651d9276647e
+SIZE (mosquitto-1.4.2.tar.gz) = 323815
diff --git a/net/mosquitto/files/patch-CMakeLists.txt b/net/mosquitto/files/patch-CMakeLists.txt
index 0473e7c71d26..798cbed7df8b 100644
--- a/net/mosquitto/files/patch-CMakeLists.txt
+++ b/net/mosquitto/files/patch-CMakeLists.txt
@@ -1,8 +1,8 @@
---- CMakeLists.txt.orig 2014-10-08 21:50:07 UTC
+--- CMakeLists.txt.orig 2015-05-07 13:21:22 UTC
+++ CMakeLists.txt
-@@ -8,6 +8,9 @@ cmake_minimum_required(VERSION 2.6)
+@@ -13,6 +13,9 @@ cmake_minimum_required(VERSION 2.8)
- set (VERSION 1.3.5)
+ set (VERSION 1.4.2)
+include_directories(/usr/local/include)
+link_directories(/usr/local/lib)
@@ -10,8 +10,8 @@
if (WIN32)
execute_process(COMMAND cmd /c echo %DATE% %TIME% OUTPUT_VARIABLE TIMESTAMP
OUTPUT_STRIP_TRAILING_WHITESPACE)
-@@ -40,7 +43,7 @@ else (WIN32)
- set (LIBDIR lib${LIB_SUFFIX})
+@@ -47,7 +50,7 @@ else (WIN32)
+ set (CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${LIBDIR}")
set (INCLUDEDIR include)
set (DATAROOTDIR share)
- set (MANDIR ${DATAROOTDIR}/man)
diff --git a/net/mosquitto/files/patch-config.mk b/net/mosquitto/files/patch-config.mk
index 3dd9e7d36fa1..2ef78b9ec18a 100644
--- a/net/mosquitto/files/patch-config.mk
+++ b/net/mosquitto/files/patch-config.mk
@@ -1,7 +1,7 @@
---- config.mk.orig 2014-10-08 21:50:07 UTC
+--- config.mk.orig 2015-05-07 13:21:22 UTC
+++ config.mk
-@@ -213,7 +213,7 @@ endif
-
+@@ -241,7 +241,7 @@ ifeq ($(WITH_DOCS),yes)
+ endif
INSTALL?=install
-prefix=/usr/local
diff --git a/net/mosquitto/files/patch-lib_tls__mosq.h b/net/mosquitto/files/patch-lib_tls__mosq.h
index a41c04f3bb7d..9a2eb5daace1 100644
--- a/net/mosquitto/files/patch-lib_tls__mosq.h
+++ b/net/mosquitto/files/patch-lib_tls__mosq.h
@@ -1,6 +1,6 @@
---- lib/tls_mosq.h.orig 2014-10-08 21:50:07 UTC
+--- lib/tls_mosq.h.orig 2015-05-07 13:21:22 UTC
+++ lib/tls_mosq.h
-@@ -33,8 +33,9 @@ POSSIBILITY OF SUCH DAMAGE.
+@@ -20,8 +20,9 @@ Contributors:
#ifdef WITH_TLS
#include <openssl/ssl.h>
diff --git a/net/mosquitto/files/patch-mosquitto.conf b/net/mosquitto/files/patch-mosquitto.conf
index ebda77148a1b..c2738b9c2857 100644
--- a/net/mosquitto/files/patch-mosquitto.conf
+++ b/net/mosquitto/files/patch-mosquitto.conf
@@ -1,4 +1,4 @@
---- mosquitto.conf.orig 2014-10-08 21:50:07 UTC
+--- mosquitto.conf.orig 2015-05-07 13:21:22 UTC
+++ mosquitto.conf
@@ -32,7 +32,7 @@
# This should be set to /var/run/mosquitto.pid if mosquitto is
diff --git a/net/mosquitto/files/patch-src_CMakeLists.txt b/net/mosquitto/files/patch-src_CMakeLists.txt
index b434155dd3d5..95e2e0a49cbe 100644
--- a/net/mosquitto/files/patch-src_CMakeLists.txt
+++ b/net/mosquitto/files/patch-src_CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/CMakeLists.txt.orig 2014-10-08 21:50:07 UTC
+--- src/CMakeLists.txt.orig 2015-05-07 13:21:22 UTC
+++ src/CMakeLists.txt
-@@ -79,7 +79,7 @@ if (UNIX)
+@@ -86,7 +86,7 @@ if (UNIX)
if (APPLE)
set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
else (APPLE)
@@ -9,7 +9,7 @@
endif (APPLE)
endif (UNIX)
-@@ -100,6 +100,5 @@ if (${WITH_TLS} STREQUAL ON)
+@@ -127,6 +127,5 @@ if (${WITH_TLS} STREQUAL ON)
endif (${WITH_TLS} STREQUAL ON)
if (UNIX)
diff --git a/net/mosquitto/pkg-descr b/net/mosquitto/pkg-descr
index 81a7e7cb8228..d47578af78c4 100644
--- a/net/mosquitto/pkg-descr
+++ b/net/mosquitto/pkg-descr
@@ -1,4 +1,8 @@
-Mosquitto is an open source implementation of a server for version 3.1 of the
-MQTT protocol.
+Mosquitto is an open source (BSD licensed) message broker that implements
+the MQ Telemetry Transport protocol versions 3.1 and 3.1.1. MQTT provides
+a lightweight method of carrying out messaging using a publish/subscribe
+model. This makes it suitable for "machine to machine" messaging such as
+with low power sensors or mobile devices such as phones, embedded
+computers or microcontrollers like the Arduino.
WWW: http://mosquitto.org/
diff --git a/net/mosquitto/pkg-message b/net/mosquitto/pkg-message
new file mode 100644
index 000000000000..63b3c6d000e7
--- /dev/null
+++ b/net/mosquitto/pkg-message
@@ -0,0 +1 @@
+The mosquitto MQTT Python driver is now provided by net/py-paho-mqtt
diff --git a/net/mosquitto/pkg-plist b/net/mosquitto/pkg-plist
index ebd5042e55e3..6672eeb986fe 100644
--- a/net/mosquitto/pkg-plist
+++ b/net/mosquitto/pkg-plist
@@ -14,9 +14,6 @@ lib/libmosquitto.so.%%PORTVERSION%%
lib/libmosquittopp.so
lib/libmosquittopp.so.1
lib/libmosquittopp.so.%%PORTVERSION%%
-%%NOPYTHON%%%%PYTHON_SITELIBDIR%%/mosquitto-%%PORTVERSION%%-py%%PYTHON_VER%%.egg-info
-%%NOPYTHON%%%%PYTHON_SITELIBDIR%%/mosquitto.py
-%%NOPYTHON%%%%PYTHON_SITELIBDIR%%/mosquitto.pyc
man/man1/mosquitto_passwd.1.gz
man/man1/mosquitto_pub.1.gz
man/man1/mosquitto_sub.1.gz