aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-08-18 17:03:11 +0000
committerSteve Wills <swills@FreeBSD.org>2017-08-18 17:03:11 +0000
commit964f439c259faa895e5da50491d1cc20a9795f4a (patch)
tree1fcd9b669c8e2ac33545be66687f68258c9a470f /net/mosquitto
parent22283b152a6ff94208c74ce7e73a45cefae5de2e (diff)
downloadports-964f439c259faa895e5da50491d1cc20a9795f4a.tar.gz
ports-964f439c259faa895e5da50491d1cc20a9795f4a.zip
net/mosquitto: Fails to build with WS option enabled
PR: 220827 Submitted by: stl@koffein.net Approved by: joe@thrallingpenguin.com (maintainer)
Notes
Notes: svn path=/head/; revision=448259
Diffstat (limited to 'net/mosquitto')
-rw-r--r--net/mosquitto/files/patch-lib_mosquitto__internal.h33
-rw-r--r--net/mosquitto/files/patch-src_CMakeLists.txt14
2 files changed, 44 insertions, 3 deletions
diff --git a/net/mosquitto/files/patch-lib_mosquitto__internal.h b/net/mosquitto/files/patch-lib_mosquitto__internal.h
new file mode 100644
index 000000000000..1f99124cebc8
--- /dev/null
+++ b/net/mosquitto/files/patch-lib_mosquitto__internal.h
@@ -0,0 +1,33 @@
+--- lib/mosquitto_internal.h.orig 2017-07-18 16:25:21 UTC
++++ lib/mosquitto_internal.h
+@@ -30,11 +30,7 @@ Contributors:
+ #endif
+ #include <stdlib.h>
+
+-#if defined(WITH_THREADING) && !defined(WITH_BROKER)
+-# include <pthread.h>
+-#else
+-# include <dummypthread.h>
+-#endif
++#include <pthread.h>
+
+ #ifdef WITH_SRV
+ # include <ares.h>
+@@ -184,7 +180,7 @@ struct mosquitto {
+ #endif
+ bool want_write;
+ bool want_connect;
+-#if defined(WITH_THREADING) && !defined(WITH_BROKER)
++
+ pthread_mutex_t callback_mutex;
+ pthread_mutex_t log_callback_mutex;
+ pthread_mutex_t msgtime_mutex;
+@@ -195,7 +191,7 @@ struct mosquitto {
+ pthread_mutex_t out_message_mutex;
+ pthread_mutex_t mid_mutex;
+ pthread_t thread_id;
+-#endif
++
+ bool clean_session;
+ #ifdef WITH_BROKER
+ bool is_dropping;
diff --git a/net/mosquitto/files/patch-src_CMakeLists.txt b/net/mosquitto/files/patch-src_CMakeLists.txt
index 95e2e0a49cbe..1b7c83cab29e 100644
--- a/net/mosquitto/files/patch-src_CMakeLists.txt
+++ b/net/mosquitto/files/patch-src_CMakeLists.txt
@@ -1,6 +1,14 @@
---- src/CMakeLists.txt.orig 2015-05-07 13:21:22 UTC
+--- src/CMakeLists.txt.orig 2016-08-17 11:05:14 UTC
+++ src/CMakeLists.txt
-@@ -86,7 +86,7 @@ if (UNIX)
+@@ -77,6 +77,7 @@ if (WIN32 OR CYGWIN)
+ endif (WIN32 OR CYGWIN)
+
+ add_definitions (-DWITH_BROKER)
++add_definitions (-DWITH_THREADING)
+
+ add_executable(mosquitto ${MOSQ_SRCS})
+
+@@ -86,7 +87,7 @@ if (UNIX)
if (APPLE)
set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
else (APPLE)
@@ -9,7 +17,7 @@
endif (APPLE)
endif (UNIX)
-@@ -127,6 +127,5 @@ if (${WITH_TLS} STREQUAL ON)
+@@ -127,6 +128,5 @@ if (${WITH_TLS} STREQUAL ON)
endif (${WITH_TLS} STREQUAL ON)
if (UNIX)