aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-05-04 18:51:42 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-05-04 18:51:42 +0000
commit20afb377f3216d1d2e0a59de69eba7b701898e96 (patch)
tree9f6a172605b95b370f1a0bfeb68d4c6b930b1f83 /net/mtr
parentb2f888ec6a4faee6634551271bbf3c010783b4e3 (diff)
downloadports-20afb377f3216d1d2e0a59de69eba7b701898e96.tar.gz
ports-20afb377f3216d1d2e0a59de69eba7b701898e96.zip
- Update to 0.71
- Hand maintainership to submitter PR: 96736 Submitted by: Rainer Alves <rainer.alves@gmail.com>
Notes
Notes: svn path=/head/; revision=161355
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile9
-rw-r--r--net/mtr/distinfo6
-rw-r--r--net/mtr/files/patch-configure51
-rw-r--r--net/mtr/files/patch-dns.c21
-rw-r--r--net/mtr/pkg-descr6
5 files changed, 77 insertions, 16 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 98c69ccb9761..3cdbc5db7976 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= mtr
-PORTVERSION= 0.70
+PORTVERSION= 0.71
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
- ftp://ftp.netsw.org/net/ip/audit/packets/ \
- ftp://ftp.gw.com/mirrors/pub/unix/mtr/
+ http://www.mirrors.wiretapped.net/security/network-mapping/mtr/ \
+ http://gd.tuwien.ac.at/infosys/network/tools/mtr/ \
+ http://mirrors.evolva.ro/util/mtr/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= Traceroute and ping in a single graphical network diagnostic tool
GNU_CONFIGURE= yes
diff --git a/net/mtr/distinfo b/net/mtr/distinfo
index cfa67dbac31e..dbd57eacdff0 100644
--- a/net/mtr/distinfo
+++ b/net/mtr/distinfo
@@ -1,3 +1,3 @@
-MD5 (mtr-0.70.tar.gz) = 3011726717c60972ecbbb53c74f31e84
-SHA256 (mtr-0.70.tar.gz) = 2e3ae5b774f24e5d1ffaafe1947295cd9fd3e3a87f8d0ae1ad8808aaba1990c3
-SIZE (mtr-0.70.tar.gz) = 201017
+MD5 (mtr-0.71.tar.gz) = 8c1c9f5db2c599eea3b12bfed8b80618
+SHA256 (mtr-0.71.tar.gz) = b742c46797ba23000e149c99127580d541ed44a69b5bbc44323211665c95e02a
+SIZE (mtr-0.71.tar.gz) = 205442
diff --git a/net/mtr/files/patch-configure b/net/mtr/files/patch-configure
new file mode 100644
index 000000000000..08d36b641346
--- /dev/null
+++ b/net/mtr/files/patch-configure
@@ -0,0 +1,51 @@
+--- configure.orig Fri Mar 24 03:46:43 2006
++++ configure Wed May 3 19:00:36 2006
+@@ -6817,7 +6817,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lresolv $LIBS"
++LIBS="$LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -6876,10 +6876,10 @@
+ echo "${ECHO_T}$ac_cv_lib_resolv_res_mkquery" >&6
+ if test $ac_cv_lib_resolv_res_mkquery = yes; then
+ cat >>confdefs.h <<_ACEOF
+-#define HAVE_LIBRESOLV 1
++#define HAVE_LIBRESOLV 0
+ _ACEOF
+
+- LIBS="-lresolv $LIBS"
++ LIBS="$LIBS"
+
+ else
+
+@@ -6889,7 +6889,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lresolv $LIBS"
++LIBS="$LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -6951,7 +6951,7 @@
+ #define HAVE_LIBRESOLV 1
+ _ACEOF
+
+- LIBS="-lresolv $LIBS"
++ LIBS="$LIBS"
+
+ else
+ { { echo "$as_me:$LINENO: error: No resolver library found" >&5
+@@ -6965,7 +6965,7 @@
+
+ fi
+
+-LIBS="$LIBS -lresolv"
++LIBS="$LIBS"
+
+ echo "$as_me:$LINENO: checking for herror" >&5
+ echo $ECHO_N "checking for herror... $ECHO_C" >&6
diff --git a/net/mtr/files/patch-dns.c b/net/mtr/files/patch-dns.c
index b51c74df6e93..c7ab59bcb257 100644
--- a/net/mtr/files/patch-dns.c
+++ b/net/mtr/files/patch-dns.c
@@ -1,6 +1,20 @@
---- dns.c 2006-03-22 19:45:58.000000000 -1000
-+++ dns.c 2006-03-25 11:41:31.000000000 -1000
-@@ -1357,7 +1357,7 @@
+--- dns.c.orig Thu Mar 23 02:45:58 2006
++++ dns.c Wed May 3 18:48:01 2006
+@@ -48,11 +48,13 @@
+ #include "dns.h"
+ #include "net.h"
+
++/*
+ #ifdef NO_STRERROR
+ extern int sys_nerr;
+ extern char *sys_errlist[];
+ #define strerror(errno) (((errno) >= 0 && (errno) < sys_nerr) ? sys_errlist[errno] : "unlisted error")
+ #endif
++*/
+
+ /* Hmm, it seems Irix requires this */
+ extern int errno;
+@@ -1357,7 +1359,7 @@
#ifdef ENABLE_IPV6
/* Returns an ip6.arpa character string. */
void addr2ip6arpa( ip_t * ip, char * buf ) {
@@ -8,3 +22,4 @@
+ unsigned char * p = (unsigned char *) ip;
char * b = buf;
int i;
+
diff --git a/net/mtr/pkg-descr b/net/mtr/pkg-descr
index cdf6caa027a9..1d4b85bca7d5 100644
--- a/net/mtr/pkg-descr
+++ b/net/mtr/pkg-descr
@@ -1,10 +1,4 @@
mtr combines the functionality of the "traceroute" and "ping" programs
into a single network diagnostic tool.
-Authors: Matt Kimball <mkimball@xmission.com> is the primary author of mtr.
- Roger Wolff <R.E.Wolff@BitWizard.nl> is currently maintaing mtr.
WWW: http://www.bitwizard.nl/mtr/
-
-Ported to FreeBSD by:
-Bill Fumerola (billf@chc-chimes.com)
-Gianmarco Giovannelli (gmarco@giovannelli.it)