aboutsummaryrefslogtreecommitdiff
path: root/net/mtr
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-26 14:50:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-26 14:50:03 +0000
commit8668d82cc1d50eefd9d09b1966c551df56b8b79a (patch)
treeef386f875ac59eee7a1f050aad24fee503f584d6 /net/mtr
parentbb522c092e84083c3f44906cfcdb2fb9c6880da2 (diff)
downloadports-8668d82cc1d50eefd9d09b1966c551df56b8b79a.tar.gz
ports-8668d82cc1d50eefd9d09b1966c551df56b8b79a.zip
- Update to 0.73
PR: 123088 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=212017
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile22
-rw-r--r--net/mtr/distinfo6
-rw-r--r--net/mtr/files/patch-aclocal.m4398
-rw-r--r--net/mtr/files/patch-configure13
4 files changed, 412 insertions, 27 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 601375de6b19..de1bd525dcb5 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mtr
-PORTVERSION= 0.72
-PORTREVISION= 2
+PORTVERSION= 0.73
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
http://www.mirrors.wiretapped.net/security/network-mapping/mtr/ \
@@ -17,8 +16,9 @@ MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Traceroute and ping in a single graphical network diagnostic tool
-GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
USE_GMAKE= yes
+USE_AUTOTOOLS= automake:19 autoheader:261 autoconf:261
MAN8= mtr.8
PLIST_FILES= sbin/mtr
@@ -42,15 +42,15 @@ CONFIGURE_ARGS=--without-gtk --with-gtk-prefix=/nonexistant
CONFIGURE_ARGS+=--disable-ipv6
.endif
-post-configure:
- @${REINPLACE_CMD} -e 's|-lresolv||g' ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} -e '/getopt/d' ${WRKSRC}/Makefile.am
post-install:
- @${ECHO} ""
- @${ECHO} "${PREFIX}/sbin/mtr is setuid \"root\" "
- @${ECHO} ""
- @${ECHO} "Please read about potential security issues"
- @${ECHO} "in file ${WRKSRC}/SECURITY (not installed)"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "${PREFIX}/sbin/mtr is setuid \"root\" "
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please read about potential security issues"
+ @${ECHO_MSG} "in file ${WRKSRC}/SECURITY (not installed)"
+ @${ECHO_MSG} ""
.include <bsd.port.mk>
diff --git a/net/mtr/distinfo b/net/mtr/distinfo
index 29ba558fb072..9077e8cdcbd8 100644
--- a/net/mtr/distinfo
+++ b/net/mtr/distinfo
@@ -1,3 +1,3 @@
-MD5 (mtr-0.72.tar.gz) = d771061f8da96b80ecca2f69a3a2d594
-SHA256 (mtr-0.72.tar.gz) = 1473b7880cd3570cff59fb9692c08c8579c334cc04d5a1df092088f1570318db
-SIZE (mtr-0.72.tar.gz) = 295845
+MD5 (mtr-0.73.tar.gz) = 52223cc34c72092a0392865356a3dc76
+SHA256 (mtr-0.73.tar.gz) = 30bdf752ac048dd160aa28d5caff1ffe0986dd4df046c397087fa1d8c8e1ab51
+SIZE (mtr-0.73.tar.gz) = 558744
diff --git a/net/mtr/files/patch-aclocal.m4 b/net/mtr/files/patch-aclocal.m4
new file mode 100644
index 000000000000..09d90d4cb220
--- /dev/null
+++ b/net/mtr/files/patch-aclocal.m4
@@ -0,0 +1,398 @@
+--- aclocal.m4.orig 2008-04-08 01:32:46.000000000 +0900
++++ aclocal.m4 2008-04-13 02:57:08.000000000 +0900
+@@ -1057,3 +860,395 @@
+ AC_SUBST([am__untar])
+ ]) # _AM_PROG_TAR
+
++# Configure paths for GTK+
++# Owen Taylor 1997-2001
++
++dnl AM_PATH_GTK_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
++dnl pass to pkg-config
++dnl
++AC_DEFUN([AM_PATH_GTK_2_0],
++[dnl
++dnl Get the cflags and libraries from pkg-config
++dnl
++AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
++ , enable_gtktest=yes)
++
++ pkg_config_args=gtk+-2.0
++ for module in . $4
++ do
++ case "$module" in
++ gthread)
++ pkg_config_args="$pkg_config_args gthread-2.0"
++ ;;
++ esac
++ done
++
++ no_gtk=""
++
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++
++ if test x$PKG_CONFIG != xno ; then
++ if pkg-config --atleast-pkgconfig-version 0.7 ; then
++ :
++ else
++ echo "*** pkg-config too old; version 0.7 or better required."
++ no_gtk=yes
++ PKG_CONFIG=no
++ fi
++ else
++ no_gtk=yes
++ fi
++
++ min_gtk_version=ifelse([$1], ,2.0.0,$1)
++ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
++
++ if test x$PKG_CONFIG != xno ; then
++ ## don't try to run the test against uninstalled libtool libs
++ if $PKG_CONFIG --uninstalled $pkg_config_args; then
++ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
++ enable_gtktest=no
++ fi
++
++ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
++ :
++ else
++ no_gtk=yes
++ fi
++ fi
++
++ if test x"$no_gtk" = x ; then
++ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
++ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
++ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_gtktest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
++dnl checks the results of pkg-config to some extent)
++dnl
++ rm -f conf.gtktest
++ AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ system ("touch conf.gtktest");
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_gtk_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_gtk_version");
++ exit(1);
++ }
++
++ if ((gtk_major_version != $gtk_config_major_version) ||
++ (gtk_minor_version != $gtk_config_minor_version) ||
++ (gtk_micro_version != $gtk_config_micro_version))
++ {
++ printf("\n*** 'pkg-config --modversion gtk+-2.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
++ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf ("*** was found! If pkg-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
++ printf("*** to point to the correct configuration files\n");
++ }
++ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++ (gtk_minor_version != GTK_MINOR_VERSION) ||
++ (gtk_micro_version != GTK_MICRO_VERSION))
++ {
++ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ }
++ else
++ {
++ if ((gtk_major_version > major) ||
++ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
++ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_gtk" = x ; then
++ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** A new enough version of pkg-config was not found."
++ echo "*** See http://pkgconfig.sourceforge.net"
++ else
++ if test -f conf.gtktest ; then
++ :
++ else
++ echo "*** Could not run GTK+ test program, checking why..."
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
++ AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
++ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GTK_CFLAGS=""
++ GTK_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GTK_CFLAGS)
++ AC_SUBST(GTK_LIBS)
++ rm -f conf.gtktest
++])
++
++# Configure paths for GTK+
++# Owen Taylor 97-11-3
++
++dnl AM_PATH_GTK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK, and define GTK_CFLAGS and GTK_LIBS
++dnl
++AC_DEFUN(AM_PATH_GTK,
++[dnl
++dnl Get the cflags and libraries from the gtk-config script
++dnl
++AC_ARG_WITH(gtk-prefix,[ --with-gtk-prefix=PFX Prefix where GTK is installed (optional)],
++ gtk_config_prefix="$withval", gtk_config_prefix="")
++AC_ARG_WITH(gtk-exec-prefix,[ --with-gtk-exec-prefix=PFX Exec prefix where GTK is installed (optional)],
++ gtk_config_exec_prefix="$withval", gtk_config_exec_prefix="")
++AC_ARG_ENABLE(gtktest, [ --disable-gtktest Do not try to compile and run a test GTK program],
++ , enable_gtktest=yes)
++
++ for module in . $4
++ do
++ case "$module" in
++ gthread)
++ gtk_config_args="$gtk_config_args gthread"
++ ;;
++ esac
++ done
++
++ if test x$gtk_config_exec_prefix != x ; then
++ gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
++ if test x${GTK_CONFIG+set} != xset ; then
++ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
++ fi
++ fi
++ if test x$gtk_config_prefix != x ; then
++ gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
++ if test x${GTK_CONFIG+set} != xset ; then
++ GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
++ fi
++ fi
++
++ AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
++ min_gtk_version=ifelse([$1], ,0.99.7,$1)
++ AC_MSG_CHECKING(for GTK - version >= $min_gtk_version)
++ no_gtk=""
++ if test "$GTK_CONFIG" = "no" ; then
++ no_gtk=yes
++ else
++ GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
++ GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
++ gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_gtktest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK is sufficiently new. (Also sanity
++dnl checks the results of gtk-config to some extent
++dnl
++ rm -f conf.gtktest
++ AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ system ("touch conf.gtktest");
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_gtk_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_gtk_version");
++ exit(1);
++ }
++
++ if ((gtk_major_version != $gtk_config_major_version) ||
++ (gtk_minor_version != $gtk_config_minor_version) ||
++ (gtk_micro_version != $gtk_config_micro_version))
++ {
++ printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
++ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf ("*** was found! If gtk-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
++ printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
++ printf("*** before re-running configure\n");
++ }
++#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
++ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++ (gtk_minor_version != GTK_MINOR_VERSION) ||
++ (gtk_micro_version != GTK_MICRO_VERSION))
++ {
++ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ }
++#endif /* defined (GTK_MAJOR_VERSION) ... */
++ else
++ {
++ if ((gtk_major_version > major) ||
++ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
++ printf("*** correct copy of gtk-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_gtk" = x ; then
++ AC_MSG_RESULT(yes)
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$GTK_CONFIG" = "no" ; then
++ echo "*** The gtk-config script installed by GTK could not be found"
++ echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
++ echo "*** your path, or set the GTK_CONFIG environment variable to the"
++ echo "*** full path to gtk-config."
++ else
++ if test -f conf.gtktest ; then
++ :
++ else
++ echo "*** Could not run GTK test program, checking why..."
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
++ AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GTK or finding the wrong"
++ echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
++ echo "***"
++ echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
++ echo "*** came with the system with the command"
++ echo "***"
++ echo "*** rpm --erase --nodeps gtk gtk-devel" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GTK was incorrectly installed"
++ echo "*** or that you have moved GTK since it was installed. In the latter case, you"
++ echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GTK_CFLAGS=""
++ GTK_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GTK_CFLAGS)
++ AC_SUBST(GTK_LIBS)
++ rm -f conf.gtktest
++])
++
diff --git a/net/mtr/files/patch-configure b/net/mtr/files/patch-configure
deleted file mode 100644
index 74790002695d..000000000000
--- a/net/mtr/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: configure
-diff -u configure.orig configure
---- configure.orig Sat Sep 30 04:41:56 2006
-+++ configure Wed Nov 8 02:02:41 2006
-@@ -7287,8 +7287,6 @@
-
- fi
-
--LIBS="$LIBS -lresolv"
--
- echo "$as_me:$LINENO: checking for herror" >&5
- echo $ECHO_N "checking for herror... $ECHO_C" >&6
- if test "${ac_cv_func_herror+set}" = set; then