aboutsummaryrefslogtreecommitdiff
path: root/net/nats-nkeys
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2022-02-26 17:12:04 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2022-02-27 12:13:37 +0000
commitd45350b6957216324fed102a6731d423cef5d83e (patch)
tree5e8de71eaf3cf69caa7683c8e6e5d5e5dc9f2cc0 /net/nats-nkeys
parentf08a2e0baf72597527b2b1d2faa4e4104a34b9c7 (diff)
downloadports-d45350b6957216324fed102a6731d423cef5d83e.tar.gz
ports-d45350b6957216324fed102a6731d423cef5d83e.zip
net/nats-nkeys: add new port
This is a command line utility to manage NATS Ed25519 keys.
Diffstat (limited to 'net/nats-nkeys')
-rw-r--r--net/nats-nkeys/Makefile27
-rw-r--r--net/nats-nkeys/distinfo5
-rw-r--r--net/nats-nkeys/pkg-descr17
3 files changed, 49 insertions, 0 deletions
diff --git a/net/nats-nkeys/Makefile b/net/nats-nkeys/Makefile
new file mode 100644
index 000000000000..8a45ce069c3d
--- /dev/null
+++ b/net/nats-nkeys/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= nkeys
+PORTVERSION= 0.3.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+PKGNAMEPREFIX= nats-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Public-key signature system based on Ed25519 for the NATS ecosystem
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+GO_TARGET= ./nk
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= nats-io
+GH_TUPLE= golang:crypto:e6e6c4f2bb5b:golang_crypto/vendor/golang.org/x/crypto
+
+PLIST_FILES= bin/nk \
+ share/doc/${PORTNAME}/README.md
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/nats-nkeys/distinfo b/net/nats-nkeys/distinfo
new file mode 100644
index 000000000000..2091e5af8c43
--- /dev/null
+++ b/net/nats-nkeys/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1645893896
+SHA256 (nats-io-nkeys-v0.3.0_GH0.tar.gz) = ea281df5dc380b84f61c3712b367f02957cff4cb7802e73b2b0b7588e4f6b809
+SIZE (nats-io-nkeys-v0.3.0_GH0.tar.gz) = 19986
+SHA256 (golang-crypto-e6e6c4f2bb5b_GH0.tar.gz) = 06bad34612d7bc2c5ce03762571e55095959f6f725f3e6419051d0fe4aa6a518
+SIZE (golang-crypto-e6e6c4f2bb5b_GH0.tar.gz) = 1726200
diff --git a/net/nats-nkeys/pkg-descr b/net/nats-nkeys/pkg-descr
new file mode 100644
index 000000000000..a0912954fe48
--- /dev/null
+++ b/net/nats-nkeys/pkg-descr
@@ -0,0 +1,17 @@
+NATS is an open-source, cloud-native messaging system.
+
+This is a command line utility to manage NATS Ed25519 keys.
+
+The NATS ecosystem will be moving to Ed25519 keys for identity,
+authentication and authorization for entities such as Accounts,
+Users, Servers and Clusters.
+
+Ed25519 is fast and resistant to side channel attacks. Generation
+of a seed key is all that is needed to be stored and kept safe, as
+the seed can generate both the public and private keys.
+
+The NATS system will utilize Ed25519 keys, meaning that NATS systems
+will never store or even have access to any private keys. Authentication
+will utilize a random challenge response mechanism.
+
+WWW: https://github.com/nats-io/nkeys