aboutsummaryrefslogtreecommitdiff
path: root/net/ndpi/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-07 13:29:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-07 13:29:17 +0000
commitec0a394fe17e680d96de73843593b471702f8dfb (patch)
tree87c0cfc09a737e5755ed46c000e9c6e99ce418f9 /net/ndpi/Makefile
parent3dbe47d57049004a6b00bb61ca1327976b984f87 (diff)
downloadports-ec0a394fe17e680d96de73843593b471702f8dfb.tar.gz
ports-ec0a394fe17e680d96de73843593b471702f8dfb.zip
net/ndpi: Update version 1.5.1=>1.6
- Update DISTNAME according to upstream
Notes
Notes: svn path=/head/; revision=388698
Diffstat (limited to 'net/ndpi/Makefile')
-rw-r--r--net/ndpi/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
index 548ebd5ceb33..4b41c857395b 100644
--- a/net/ndpi/Makefile
+++ b/net/ndpi/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= ndpi
-PORTVERSION= 1.5.1
+PORTVERSION= 1.6
CATEGORIES= net
MASTER_SITES= SF/ntop/nDPI
-DISTNAME= libndpi-${PORTVERSION}
+DISTNAME= nDPI-${PORTVERSION}
MAINTAINER= bofh@FreeBSD.org
COMMENT= NTOP-maintained superset of the popular OpenDPI library
@@ -20,10 +20,14 @@ LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -ljson-c
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= libtool pathfix pkgconfig compiler:c++11-lang
-WRKSRC= ${WRKDIR}/libndpi-${PORTVERSION}
+USES= autoreconf libtool pathfix pkgconfig compiler:c++11-lang
+WRKSRC= ${WRKDIR}/nDPI-${PORTVERSION}
INSTALL_TARGET= install-strip
-PLIST_SUB= MAJOR_VER=${PORTVERSION}
+PLIST_SUB= MAJOR_VER=${PORTVERSION}.0
+
+post-patch:
+ ${REINPLACE_CMD} 's|$$(libdir)|$$(libdir)data|' \
+ ${WRKSRC}/Makefile.am
.include <bsd.port.mk>