aboutsummaryrefslogtreecommitdiff
path: root/net/neatvnc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-07-16 16:49:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-07-16 16:49:32 +0000
commit20a22252591f53b2afbb5021d2dcd6019307eae0 (patch)
tree19fef7ed6036a998a5431733eeda4aa3220f67a6 /net/neatvnc
parent98fd77d1da3dd2d02d11212bfc747d5370feca21 (diff)
downloadports-20a22252591f53b2afbb5021d2dcd6019307eae0.tar.gz
ports-20a22252591f53b2afbb5021d2dcd6019307eae0.zip
net/wayvnc: update to 0.1.2.140 (snapshot)
Notes
Notes: svn path=/head/; revision=542372
Diffstat (limited to 'net/neatvnc')
-rw-r--r--net/neatvnc/Makefile8
-rw-r--r--net/neatvnc/distinfo6
-rw-r--r--net/neatvnc/files/patch-default-target16
3 files changed, 13 insertions, 17 deletions
diff --git a/net/neatvnc/Makefile b/net/neatvnc/Makefile
index 135546d87f15..f2b4dcd377a2 100644
--- a/net/neatvnc/Makefile
+++ b/net/neatvnc/Makefile
@@ -2,8 +2,8 @@
PORTNAME= neatvnc
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.0
-PORTREVISION= 1
+DISTVERSION= 0.1.0-54
+DISTVERSIONSUFFIX= -g33eda8c
CATEGORIES= net
MAINTAINER= jbeich@FreeBSD.org
@@ -13,7 +13,7 @@ LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/libdrm/drm_fourcc.h:graphics/libdrm
-LIB_DEPENDS= libuv.so:devel/libuv
+LIB_DEPENDS= libaml.so:devel/aml
USES= compiler:c11 meson pkgconfig xorg
USE_GITHUB= yes
@@ -28,6 +28,6 @@ GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_MESON_ENABLED= tls
JPEG_LIB_DEPENDS= libturbojpeg.so:graphics/libjpeg-turbo
-JPEG_MESON_ENABLED= tight-encoding
+JPEG_MESON_ENABLED= jpeg
.include <bsd.port.mk>
diff --git a/net/neatvnc/distinfo b/net/neatvnc/distinfo
index f0dc3186c389..2a4f8887364a 100644
--- a/net/neatvnc/distinfo
+++ b/net/neatvnc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1582326259
-SHA256 (any1-neatvnc-v0.1.0_GH0.tar.gz) = b2a99cd85ad5414f7d8a5203107d1ce6b65d57bec8d28d1efc7362de8b4c7923
-SIZE (any1-neatvnc-v0.1.0_GH0.tar.gz) = 633304
+TIMESTAMP = 1594498587
+SHA256 (any1-neatvnc-v0.1.0-54-g33eda8c_GH0.tar.gz) = cc7fbce9b9e79a2b370d4698e063301d013cbf08e2945e06da4e13167a51ed3c
+SIZE (any1-neatvnc-v0.1.0-54-g33eda8c_GH0.tar.gz) = 548786
diff --git a/net/neatvnc/files/patch-default-target b/net/neatvnc/files/patch-default-target
index 19b9f6ca2538..d31ecc682659 100644
--- a/net/neatvnc/files/patch-default-target
+++ b/net/neatvnc/files/patch-default-target
@@ -1,24 +1,20 @@
Revert https://github.com/any1/neatvnc/commit/a43bb5d3d438 in favor of CPUTYPE.
-Not all i386 and amd64 support AVX and not all armv6 support NEON.
+amd64 implies SSE2 while not all armv6 have NEON.
-https://github.com/any1/wayvnc/issues/34
-
---- meson.build.orig 2020-02-21 23:04:19 UTC
+--- meson.build.orig 2020-07-11 20:16:27 UTC
+++ meson.build
-@@ -19,16 +19,6 @@ if buildtype == 'release' or buildtype == 'plain'
+@@ -21,14 +21,6 @@ if buildtype != 'debug' and buildtype != 'debugoptimiz
c_args += '-DNDEBUG'
endif
-cpu = host_machine.cpu_family()
-
-if cpu == 'x86_64'
-- c_args += '-mavx'
+- c_args += '-m' + get_option('x86_64-simd')
-elif cpu == 'arm'
- c_args += '-mfpu=neon'
-endif
-
--add_project_arguments(c_args, language: 'c')
--
- cc = meson.get_compiler('c')
+ add_project_arguments(c_args, language: 'c')
- libm = cc.find_library('m', required: false)
+ cc = meson.get_compiler('c')