aboutsummaryrefslogtreecommitdiff
path: root/net/nemesis
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-07-08 04:24:21 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-07-08 04:24:21 +0000
commit8e8873a76d5052d5eb117984aee523e4d3d9cd97 (patch)
tree46c9c4fb96cee82c636ddf6f7876e4f86b0bfd42 /net/nemesis
parentbf4158406433758b6e28d8162784d62b4b61fd28 (diff)
downloadports-8e8873a76d5052d5eb117984aee523e4d3d9cd97.tar.gz
ports-8e8873a76d5052d5eb117984aee523e4d3d9cd97.zip
Nemesis is a command line, portable "human IP stack". It can be useful for
easy injection of packet streams from simple shell scripts. It supports 8 protocols (ARP, DNS, ICMP, IGMP, OSPF, RIP, TCP, UDP), and packets can be injected on either Layer 2 or Layer 3.
Notes
Notes: svn path=/head/; revision=30355
Diffstat (limited to 'net/nemesis')
-rw-r--r--net/nemesis/Makefile25
-rw-r--r--net/nemesis/distinfo1
-rw-r--r--net/nemesis/files/patch-configure11
-rw-r--r--net/nemesis/pkg-comment1
-rw-r--r--net/nemesis/pkg-descr22
-rw-r--r--net/nemesis/pkg-plist9
6 files changed, 69 insertions, 0 deletions
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
new file mode 100644
index 000000000000..b30605713c60
--- /dev/null
+++ b/net/nemesis/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: nemesis
+# Date created: Fri July 07, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= nemesis
+PORTVERSION= 1.1
+CATEGORIES= net security
+MASTER_SITES= http://celerity.bartoli.org/nemesis/ \
+ http://www.packetfactory.net/Projects/nemesis/ \
+ http://www.nol.net/~halogen/
+
+MAINTAINER= obrien@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a::net/libnet
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-icmp.1 nemesis-igmp.1
+MAN1+= nemesis-ospf.1 nemesis-rip.1 nemesis-tcp.1 nemesis-udp.1
+
+.include <bsd.port.mk>
diff --git a/net/nemesis/distinfo b/net/nemesis/distinfo
new file mode 100644
index 000000000000..5a9a2ef6671f
--- /dev/null
+++ b/net/nemesis/distinfo
@@ -0,0 +1 @@
+MD5 (nemesis-1.1.tar.gz) = 5c777f73900663f17df8da296aefc4c5
diff --git a/net/nemesis/files/patch-configure b/net/nemesis/files/patch-configure
new file mode 100644
index 000000000000..84d5fe932aec
--- /dev/null
+++ b/net/nemesis/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 19:38:00 2000
++++ configure Fri Jul 7 11:46:04 2000
+@@ -639,7 +639,7 @@
+
+ if test -z "${CFLAGS}"; then
+ if test -z "${CCOPTS}"; then
+- CCOPTS='-O3 -funroll-loops -fomit-frame-pointer -pipe'
++ CCOPTS='-O -funroll-loops -fomit-frame-pointer -pipe'
+ fi
+ CFLAGS="$CCOPTS"
+ fi
diff --git a/net/nemesis/pkg-comment b/net/nemesis/pkg-comment
new file mode 100644
index 000000000000..5b637ab9db8e
--- /dev/null
+++ b/net/nemesis/pkg-comment
@@ -0,0 +1 @@
+Network packet builder & injection suite
diff --git a/net/nemesis/pkg-descr b/net/nemesis/pkg-descr
new file mode 100644
index 000000000000..233df21b4338
--- /dev/null
+++ b/net/nemesis/pkg-descr
@@ -0,0 +1,22 @@
+Nemesis is a command line, portable "human IP stack". It can be useful for
+easy injection of packet streams from simple shell scripts. It supports
+8 protocols (ARP, DNS, ICMP, IGMP, OSPF, RIP, TCP, UDP), and packets can be
+injected on either Layer 2 or Layer 3.
+
+* nemesis-tcp -v -S 192.168.1.1 -D 192.168.2.2 -fS -fA -y 22 -P foo
+ send TCP packet (SYN/ACK) with payload from ascii file 'foo' to target's
+ ssh port from 192.168.1.1 to 192.168.2.2. (-v allows a stdout visual of
+ current injected packet)
+
+* nemesis-icmp -S 10.10.10.3 -D 10.10.10.1 -G 10.10.10.3 -i 5
+ send ICMP REDIRECT (network) packet from 10.10.10.3 to 10.10.10.1
+ with preferred gateway as source address.
+
+* nemesis-arp -v -d ne0 -H 0:1:2:3:4:5 -S 10.11.30.5 -D 10.10.15.1
+ send ARP packet through device 'ne0' from hardware source address
+ 00:01:02:03:04:05 with IP source address 10.11.30.5 to destination IP
+ address 10.10.15.1 with broadcast destination hardware address.
+ In other words, who-has the mac address of 10.10.15.1, tell 10.11.30.5
+ - assuming 00:01:02:03:04:05 is the source mac address of our 'ne0' device.
+
+WWW: http://celerity.bartoli.org/nemesis/
diff --git a/net/nemesis/pkg-plist b/net/nemesis/pkg-plist
new file mode 100644
index 000000000000..fd6b1f2b21f0
--- /dev/null
+++ b/net/nemesis/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+sbin/nemesis-arp
+sbin/nemesis-dns
+sbin/nemesis-icmp
+sbin/nemesis-igmp
+sbin/nemesis-ospf
+sbin/nemesis-rip
+sbin/nemesis-tcp
+sbin/nemesis-udp