aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk3
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2013-04-28 22:38:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2013-04-28 22:38:35 +0000
commit2a1e9949ef411560e2db4c7999ae406dba53a7f5 (patch)
treef1d798308b5ba34dbc02c0108332bc112ea91238 /net/netatalk3
parent73b9d6ba84d084550bf54053af49d0fe7978dc93 (diff)
downloadports-2a1e9949ef411560e2db4c7999ae406dba53a7f5.tar.gz
ports-2a1e9949ef411560e2db4c7999ae406dba53a7f5.zip
Update to 3.0.3 and port to using OptionsNG.
Notes
Notes: svn path=/head/; revision=316764
Diffstat (limited to 'net/netatalk3')
-rw-r--r--net/netatalk3/Makefile48
-rw-r--r--net/netatalk3/distinfo4
-rw-r--r--net/netatalk3/files/patch-etc_apfd_Makefile.in22
-rw-r--r--net/netatalk3/pkg-plist4
4 files changed, 48 insertions, 30 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 308c98570f3e..7d19ef4f71a9 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= netatalk
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTVERSION= 3.0.3
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -42,16 +41,18 @@ CONFIGURE_ARGS+= --enable-tcp-wrappers \
--with-libevent-header=${LOCALBASE}/include \
--with-libevent-lib=${LOCALBASE}/lib/event2
-OPTIONS= PAM "Enable PAM support" off \
- KRB5 "Enable Kerberos V UAM" off \
- ZEROCONF "Enable Zeroconf (Bonjour) support" on \
- LDAP "Enable LDAP support" off \
- SENDFILE "Enable sendfile support" off \
- KERBEROS "Enable Kerberos support" on
+OPTIONS_DEFINE=PAM KRB5 ZEROCONF LDAP SENDFILE KERBEROS DTRACE DBUS
+OPTIONS_DEFAULT=ZEROCONF KERBEROS DBUS
+
+ZEROCONF_DESC= Enable Zeroconf (Bonjour) support
+KRB5_DESC= Enable Kerberos V UAM
+DTRACE_DESC= Enable DTrace support
+SENDFILE_DESC= Enable Sendfile support
+
+.include <bsd.port.options.mk>
MAN1= ad.1 afpldaptest.1 afppasswd.1 apple_dump.1 asip-status.pl.1 \
- dbd.1 macusers.1 \
- netatalk-config.1 uniconv.1
+ dbd.1 macusers.1 netatalk-config.1 uniconv.1
MAN5= afp.conf.5 afp_signature.conf.5 afp_voluuid.conf.5 \
extmap.conf.5
MAN8= afpd.8 cnid_dbd.8 cnid_metad.8 netatalk.8
@@ -60,20 +61,26 @@ CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
.include <bsd.port.pre.mk>
-.if defined(WITH_KRB5)
+.if ${PORT_OPTIONS:MKRB5}
CONFIGURE_ARGS+= --enable-krbV-uam
PLIST_SUB+= NETATALKKRB5=""
.else
PLIST_SUB+= NETATALKKRB5="@comment "
.endif
-.if defined (WITH_KERBEROS)
+.if ${PORT_OPTIONS:MDTRACE}
+CONFIGURE_ARGS+= --with-dtrace
+.else
+CONFIGURE_ARGS+= --without-dtrace
+.endif
+
+.if ${PORT_OPTIONS:MKERBEROS}
CONFIGURE_ARGS+= --with-kerberos
.else
CONFIGURE_ARGS+= --without-kerberos
.endif
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
CONFIGURE_ARGS+= --with-pam
PLIST_SUB+= NETATALKPAM=""
.else
@@ -81,7 +88,7 @@ CONFIGURE_ARGS+= --without-pam
PLIST_SUB+= NETATALKPAM="@comment "
.endif
-.if defined (WITH_ZEROCONF)
+.if ${PORT_OPTIONS:MZEROCONF}
CONFIGURE_ARGS+= --enable-zeroconf=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
@@ -92,7 +99,7 @@ CONFIGURE_ARGS+= --disable-zerconf
SUB_LIST+= ZEROCONF=""
.endif
-.if defined (WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_OPENLDAP= yes
@@ -100,12 +107,21 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --without-ldap
.endif
-.if defined (WITH_SENDFILE)
+.if ${PORT_OPTIONS:MSENDFILE}
CONFIGURE_ARGS+= --enable-sendfile
.else
CONFIGURE_ARGS+= --disable-sendfile
.endif
+.if ${PORT_OPTIONS:MDBUS} || exists(${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc)
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus
+PLIST_SUB+= DBUS=""
+MAN1+= afpstats.1
+.else
+PLIST_SUB+= DBUS="@comment "
+.endif
+
.if ${OSVERSION} < 800031
PLIST_SUB+= ATFUNCS="@comment "
.else
diff --git a/net/netatalk3/distinfo b/net/netatalk3/distinfo
index dfa3c80dba43..96c8a16b11bb 100644
--- a/net/netatalk3/distinfo
+++ b/net/netatalk3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netatalk-3.0.2.tar.bz2) = 0e414e1afae9726f4819aaefd15bd27658fcdf38800b468cbddc5de4247141fe
-SIZE (netatalk-3.0.2.tar.bz2) = 1643396
+SHA256 (netatalk-3.0.3.tar.bz2) = e15e30d54ea720dce527555cd1278947ecc22b4dbde051929204e3818cdd1325
+SIZE (netatalk-3.0.3.tar.bz2) = 1656819
diff --git a/net/netatalk3/files/patch-etc_apfd_Makefile.in b/net/netatalk3/files/patch-etc_apfd_Makefile.in
index 2c59cf360086..59b1fdda0526 100644
--- a/net/netatalk3/files/patch-etc_apfd_Makefile.in
+++ b/net/netatalk3/files/patch-etc_apfd_Makefile.in
@@ -1,11 +1,11 @@
---- etc/afpd/Makefile.in.orig 2012-07-09 07:43:26.000000000 -0400
-+++ etc/afpd/Makefile.in 2012-09-03 10:41:54.000000000 -0400
-@@ -370,7 +370,7 @@ afpd_SOURCES = afp_avahi.c afp_config.c
- $(am__append_1)
- afpd_LDADD = \
- $(top_builddir)/libatalk/libatalk.la \
-- @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@
-+ @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@ @PAM_LIBS@
-
- afpd_LDFLAGS = -export-dynamic
- afpd_CFLAGS = \
+--- etc/afpd/Makefile.in.orig 2013-03-26 05:37:00.000000000 -0400
++++ etc/afpd/Makefile.in 2013-04-28 16:36:58.000000000 -0400
+@@ -401,7 +401,7 @@ afpd_SOURCES = afp_avahi.c afp_config.c
+ afpd_LDADD = $(top_builddir)/libatalk/libatalk.la @LIBGCRYPT_LIBS@ \
+ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ \
+ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@ \
+- $(am__append_7)
++ @PAM_LIBS@ $(am__append_7)
+ afpd_LDFLAGS = -export-dynamic $(am__append_6)
+ afpd_CFLAGS = @ZEROCONF_CFLAGS@ @GSSAPI_CFLAGS@ @KRB5_CFLAGS@ \
+ @PTHREAD_CFLAGS@ -DAPPLCNAME -DSERVERTEXT=\"$(SERVERTEXT)/\" \
diff --git a/net/netatalk3/pkg-plist b/net/netatalk3/pkg-plist
index fa99a4d2c103..7bc0d104112c 100644
--- a/net/netatalk3/pkg-plist
+++ b/net/netatalk3/pkg-plist
@@ -1,6 +1,7 @@
%%ATFUNCS%%bin/ad
bin/afpldaptest
bin/afppasswd
+%%DBUS%%bin/afpstats
bin/apple_dump
bin/asip-status.pl
bin/cnid2_create
@@ -10,6 +11,7 @@ bin/netatalk-config
bin/uniconv
@unexec if cmp -s %D/etc/afp.conf %D/etc/afp.conf.dist; then rm -f %D/etc/afp.conf; fi
etc/afp.conf.dist
+%%DBUS%%etc/dbus-1/system.d/netatalk-dbus.conf
@exec [ -f %B/afp.conf ] || cp %B/%f %B/afp.conf
@unexec if cmp -s %D/etc/extmap.conf %D/etc/extmap.conf.dist; then rm -f %D/etc/extmap.conf; fi
etc/extmap.conf.dist
@@ -69,7 +71,7 @@ include/atalk/volume.h
lib/libatalk.a
lib/libatalk.la
lib/libatalk.so
-lib/libatalk.so.3
+lib/libatalk.so.4
sbin/afpd
sbin/cnid_dbd
sbin/cnid_metad