aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk3
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-10-18 18:30:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-10-18 18:30:24 +0000
commitde8d2ea42beb7a283751908f22c66513fadb4f7a (patch)
treec458cfdf968605a3e2cae8f3e86c9c4910484db8 /net/netatalk3
parent5b3d0f357058d7879900b7f2f4168e77c5106415 (diff)
downloadports-de8d2ea42beb7a283751908f22c66513fadb4f7a.tar.gz
ports-de8d2ea42beb7a283751908f22c66513fadb4f7a.zip
* Properly expand %%ZEROCONF%% in the rc.d script
* While here, ensure zeroconf support is disabled at configure time if neither Avahi or mDNSResponder has been chosen PR: 213597
Notes
Notes: svn path=/head/; revision=424199
Diffstat (limited to 'net/netatalk3')
-rw-r--r--net/netatalk3/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 7b652e15910a..bc09a952c443 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 3.1.10
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -48,14 +48,15 @@ KERBEROS5_CONFIGURE_ON= --enable-krbV-uam
KERBEROS_CONFIGURE_WITH=kerberos
KERBEROS_LIB_DEPENDS=libgpg-error.so:security/libgpg-error
PAM_CONFIGURE_WITH=pam
-ZEROCONF_CONFIGURE_OFF= --disable-zeroconf
AVAHI_CONFIGURE_ON= --enable-zeroconf=${LOCALBASE}
AVAHI_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
+AVAHI_SUB_LIST= ZEROCONF="avahi_daemon"
MDNSRESPONDER_CONFIGURE_ON= --enable-zeroconf=${LOCALBASE}
MDNSRESPONDER_CONFIGURE_ENV= ac_cv_lib_avahi_client_avahi_client_new=no
MDNSRESPONDER_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
+MDNSRESPONDER_SUB_LIST= ZEROCONF="mdnsd"
LDAP_CONFIGURE_ON= --with-ldap=${LOCALBASE}
LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDAP_USE= OPENLDAP=yes
@@ -76,6 +77,11 @@ CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MAVAHI}=="" && ${PORT_OPTIONS:MMDNSRESPONDER}==""
+SUB_LIST+= ZEROCONF=""
+CONFIGURE_ARGS+=--disable-zeroconf
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \