aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-05 20:18:30 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-05 20:18:30 +0000
commit54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be (patch)
tree3b1d1321b78dcf4a659d95ca332649d8253316c1 /net/netatalk
parent454b9ce076de33c963302ac6c86affcddce681dd (diff)
downloadports-54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be.tar.gz
ports-54e44467d7a2aed3673c0a14dbbb8e6dd1bee7be.zip
. introduce ICONV_CONFIGURE_BASE variable at Mk/Uses/iconv.mk. It's value is
"--with-libiconv=${LOCALBASE}" at systems pre OSVERSION 100043 and "" (null) otherwise; . convert all ports which has CONFIGURE_ARGS=--with-libiconv=${LOCALBASE}. Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=326444
Diffstat (limited to 'net/netatalk')
-rw-r--r--net/netatalk/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 4997ce4b4db6..85e04c8079ea 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -21,6 +21,7 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
+ ${ICONV_CONFIGURE_BASE} \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE}
@@ -119,12 +120,6 @@ CONFIGURE_ARGS+= --enable-sendfile
CONFIGURE_ARGS+= --disable-sendfile
.endif
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -146,4 +141,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>