aboutsummaryrefslogtreecommitdiff
path: root/net/netstrain
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-23 10:28:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-23 10:28:57 +0000
commit41405efa6cc04df3290cfa20dd53478a4b73f039 (patch)
tree8714314147a84656c549ad542268bd1e7950d280 /net/netstrain
parent2c2bcbab310ae91a0909df8f3dd8cb98d3b73a47 (diff)
downloadports-41405efa6cc04df3290cfa20dd53478a4b73f039.tar.gz
ports-41405efa6cc04df3290cfa20dd53478a4b73f039.zip
New port: net/netstrain-3.0
A TCP preformance checking tool which also supports IPv6. PR: 54328 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> Approved by: fjoe (mentor)
Notes
Notes: svn path=/head/; revision=85430
Diffstat (limited to 'net/netstrain')
-rw-r--r--net/netstrain/Makefile29
-rw-r--r--net/netstrain/distinfo1
-rw-r--r--net/netstrain/files/patch-Makefile13
-rw-r--r--net/netstrain/pkg-descr6
-rw-r--r--net/netstrain/pkg-plist4
5 files changed, 53 insertions, 0 deletions
diff --git a/net/netstrain/Makefile b/net/netstrain/Makefile
new file mode 100644
index 000000000000..c88e9afd7501
--- /dev/null
+++ b/net/netstrain/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: netstrain
+# Date created: 10 July 2003
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= netstrain
+PORTVERSION= 3.0
+CATEGORIES= net ipv6
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+COMMENT= Tool to measure practical TCP throughput between two machines
+
+DOC_FILES= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/netstrain ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/netstraind ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/netstrain/distinfo b/net/netstrain/distinfo
new file mode 100644
index 000000000000..d196df3a2595
--- /dev/null
+++ b/net/netstrain/distinfo
@@ -0,0 +1 @@
+MD5 (netstrain-3.0.tar.gz) = ce04b79ae18c5143991ace8661baadcf
diff --git a/net/netstrain/files/patch-Makefile b/net/netstrain/files/patch-Makefile
new file mode 100644
index 000000000000..bf8051090702
--- /dev/null
+++ b/net/netstrain/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Tue Jul 22 21:21:57 2003
++++ Makefile Tue Jul 22 21:22:04 2003
+@@ -2,8 +2,8 @@
+
+ # variables
+
+-CC = gcc
+-CFLAGS = -Wall -O2
++CC ?= gcc
++CFLAGS ?= -Wall -O2
+
+ COMMON_OBJS = error.o net6emu.o
+
diff --git a/net/netstrain/pkg-descr b/net/netstrain/pkg-descr
new file mode 100644
index 000000000000..40e2035e8b07
--- /dev/null
+++ b/net/netstrain/pkg-descr
@@ -0,0 +1,6 @@
+NetStrain is a tool to measure practical data throughput between two machines
+over a TCP connection. It can be used for performance testing,
+stress/stability testing and to demonstrate various network effects. It
+supports both IPv4 and IPv6, provided the underlying system does.
+
+WWW: http://netstrain.sourceforge.net/
diff --git a/net/netstrain/pkg-plist b/net/netstrain/pkg-plist
new file mode 100644
index 000000000000..5e17cf34089b
--- /dev/null
+++ b/net/netstrain/pkg-plist
@@ -0,0 +1,4 @@
+bin/netstrain
+bin/netstraind
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%