aboutsummaryrefslogtreecommitdiff
path: root/net/nitroshare
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-04 08:33:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-04 08:33:16 +0000
commitaae5aa5ab6ac9bb55312eefa61ac9a6778fe037e (patch)
treeb4573c41d86bc3a31ca1959a914ad120e1164c5a /net/nitroshare
parent42e2fa3e82d35676adc1da38cc347e94be5a06f0 (diff)
downloadports-aae5aa5ab6ac9bb55312eefa61ac9a6778fe037e.tar.gz
ports-aae5aa5ab6ac9bb55312eefa61ac9a6778fe037e.zip
New port: net/nitroshare: Network file transfer application
Notes
Notes: svn path=/head/; revision=476341
Diffstat (limited to 'net/nitroshare')
-rw-r--r--net/nitroshare/Makefile23
-rw-r--r--net/nitroshare/distinfo3
-rw-r--r--net/nitroshare/pkg-descr17
-rw-r--r--net/nitroshare/pkg-plist65
4 files changed, 108 insertions, 0 deletions
diff --git a/net/nitroshare/Makefile b/net/nitroshare/Makefile
new file mode 100644
index 000000000000..796e7a521cfa
--- /dev/null
+++ b/net/nitroshare/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= nitroshare
+DISTVERSION= 0.3.4-642
+DISTVERSIONSUFFIX= -g2046ccb
+CATEGORIES= net
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Network file transfer application
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libqhttpengine.so:www/qhttpengine \
+ libqmdnsengine.so:net/qmdnsengine
+
+USES= cmake:outsource qt:5
+USE_GITHUB= yes
+GH_PROJECT= ${PORTNAME}-desktop
+USE_QT= core gui network widgets buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net/nitroshare/distinfo b/net/nitroshare/distinfo
new file mode 100644
index 000000000000..d600db79f717
--- /dev/null
+++ b/net/nitroshare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533370403
+SHA256 (nitroshare-nitroshare-desktop-0.3.4-642-g2046ccb_GH0.tar.gz) = 8cbbfd818276cd2d89bdcc733de57a2193c932847ff1cc43307a751f06ab6ede
+SIZE (nitroshare-nitroshare-desktop-0.3.4-642-g2046ccb_GH0.tar.gz) = 418467
diff --git a/net/nitroshare/pkg-descr b/net/nitroshare/pkg-descr
new file mode 100644
index 000000000000..cc96eef89bef
--- /dev/null
+++ b/net/nitroshare/pkg-descr
@@ -0,0 +1,17 @@
+NitroShare is designed to make transferring files from one device to another
+extremely simple.
+
+The application uses broadcast discovery to find other devices on the local
+network with NitroShare installed.
+
+Features:
+* Runs on FreeBSD/Linux/Android/macOS/Windows
+* Automatic discovery of devices on the local network
+* Simple and intuitive user interface
+* Incredibly fast transfer speeds
+* Transfer entire directories
+* Optional TLS encryption
+* Local HTTP API
+* Completely free and open-source
+
+WWW: https://nitroshare.net/
diff --git a/net/nitroshare/pkg-plist b/net/nitroshare/pkg-plist
new file mode 100644
index 000000000000..8480a5e8760e
--- /dev/null
+++ b/net/nitroshare/pkg-plist
@@ -0,0 +1,65 @@
+bin/nitroshare
+bin/nitroshare-cli
+bin/nitroshare-nmh
+bin/nitroshare-ui
+include/nitroshare/action.h
+include/nitroshare/actionregistry.h
+include/nitroshare/apiutil.h
+include/nitroshare/application.h
+include/nitroshare/bundle.h
+include/nitroshare/category.h
+include/nitroshare/config.h
+include/nitroshare/device.h
+include/nitroshare/deviceenumerator.h
+include/nitroshare/devicemodel.h
+include/nitroshare/fileutil.h
+include/nitroshare/handler.h
+include/nitroshare/handlerregistry.h
+include/nitroshare/iplugin.h
+include/nitroshare/item.h
+include/nitroshare/jsonutil.h
+include/nitroshare/logger.h
+include/nitroshare/message.h
+include/nitroshare/packet.h
+include/nitroshare/plugin.h
+include/nitroshare/pluginmodel.h
+include/nitroshare/proxymodel.h
+include/nitroshare/qtutil.h
+include/nitroshare/setting.h
+include/nitroshare/settingsregistry.h
+include/nitroshare/signalnotifier.h
+include/nitroshare/stderrwriter.h
+include/nitroshare/transfer.h
+include/nitroshare/transfermodel.h
+include/nitroshare/transport.h
+include/nitroshare/transportserver.h
+include/nitroshare/transportserverregistry.h
+lib/cmake/nitro%%DATADIR%%Config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/nitro%%DATADIR%%Config.cmake
+lib/cmake/nitro%%DATADIR%%ConfigVersion.cmake
+lib/libnitroshare.so
+lib/libnitroshare.so.0
+lib/libnitroshare.so.0.4.0
+lib/nitroshare/plugins/libabout.so
+lib/nitroshare/plugins/libapi.so
+lib/nitroshare/plugins/libautostart.so
+lib/nitroshare/plugins/libbroadcast.so
+lib/nitroshare/plugins/libdev.so
+lib/nitroshare/plugins/libdevice.so
+lib/nitroshare/plugins/libdeviceui.so
+lib/nitroshare/plugins/libfilesystem.so
+lib/nitroshare/plugins/libfilesystemui.so
+lib/nitroshare/plugins/liblan.so
+lib/nitroshare/plugins/libloggerui.so
+lib/nitroshare/plugins/libmdns.so
+lib/nitroshare/plugins/libnmh.so
+lib/nitroshare/plugins/libnotifications.so
+lib/nitroshare/plugins/libpluginui.so
+lib/nitroshare/plugins/libsettingsui.so
+lib/nitroshare/plugins/libsharebox.so
+lib/nitroshare/plugins/libstatic.so
+lib/nitroshare/plugins/libtransferui.so
+lib/nitroshare/plugins/libtray.so
+lib/nitroshare/plugins/liburl.so
+lib/nitroshare/plugins/liburlui.so
+lib/nitroshare/plugins/libwizard.so