aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2014-01-14 14:19:05 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2014-01-14 14:19:05 +0000
commit8e584a521ad16fca4270b4e31bca46b475bb2b9b (patch)
tree379cb60c067adfb6c1f2e88f7d0ed2444ace6f4f /net/nss_ldap/Makefile
parentc2e1cd79f8c534cf33c4d081e0f4c65267f40051 (diff)
downloadports-8e584a521ad16fca4270b4e31bca46b475bb2b9b.tar.gz
ports-8e584a521ad16fca4270b4e31bca46b475bb2b9b.zip
Functional changes:
- Add a SASL port option - Fix the KERBEROS ports option - it was a no-op, setting a configure flag which modifies how Kerberos was used without setting the flag that actually enables it. - Use GSSAPI instead of $ENV{KRB5CCNAME} to set the credential cache. The latter pollutes the unsuspecting application's environment and does not always work (for instance, it breaks when nss_ldap is invoked from OpenSSH, although I haven't quite determined why) - Add patches to support Heimdal in addition to MIT Kerberos. Note that I tried to ensure that the code is unchanged in the non-Heimdal case, but that I have no way of testing with MIT Kerberos. With the above changes, I have successfully configured a FreeBSD 9.2 server to authenticate users against a Microsoft Windows 2012 Active Directory server. Non-functional changes: - Modernize and stagify - Remove text in pkg-message about a change that was made ten years ago - Take maintainership as current maintainer has been AWOL for 2+ years - Bump PORTREVISION Approved by: maintainer hasn't been heard of for 2+ years
Notes
Notes: svn path=/head/; revision=339687
Diffstat (limited to 'net/nss_ldap/Makefile')
-rw-r--r--net/nss_ldap/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 5564febbf61c..8a993c1cc74c 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -3,13 +3,13 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/ \
LOCAL/martymac
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
-MAINTAINER= mikeg@bsd-box.net
+MAINTAINER= des@FreeBSD.org
COMMENT= RFC 2307 NSS module
LICENSE= GPLv2
@@ -24,11 +24,13 @@ AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
USE_OPENLDAP= yes
-OPTIONS_DEFINE= LCLASS KERBEROS
+OPTIONS_DEFINE= LCLASS KERBEROS SASL
OPTIONS_DEFAULT=LCLASS KERBEROS
LCLASS_DESC= Enable login classes via the loginClass attribute
+SASL_DESC= Use the SASL-enabled version of OpenLDAP
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib
@@ -41,17 +43,21 @@ MAN5= nss_ldap.5
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKERBEROS}
-CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-env
+CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-gssapi \
+ --enable-configurable-krb5-keytab
.endif
.if ${PORT_OPTIONS:MLCLASS}
CFLAGS+="-DHAVE_LOGIN_CLASSES"
.endif
+.if ${PORT_OPTIONS:MSASL}
+WANT_OPENLDAP_SASL = YES
+.endif
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
@@ -73,16 +79,8 @@ post-configure:
@${ECHO} "#define HAVE_RESOLV_H 1" >> ${WRKSRC}/config.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${PREFIX}/lib/nss_ldap.so.1
- ${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${MAN5PREFIX}/man/man5
-
-post-install:
- @if [ ! -f ${PREFIX}/etc/nss_ldap.conf ]; then \
- ${CP} -pv ${PREFIX}/etc/nss_ldap.conf.sample ${PREFIX}/etc/nss_ldap.conf ; \
- fi
-.if !defined(PACKAGE_BUILDING)
- @${CAT} ${PKGMESSAGE}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${STAGEDIR}/${PREFIX}/lib/nss_ldap.so.1
+ ${INSTALL_DATA} ${WRKSRC}/ldap.conf ${STAGEDIR}/${PREFIX}/etc/nss_ldap.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${STAGEDIR}/${MAN5PREFIX}/man/man5
.include <bsd.port.mk>