aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2009-08-18 21:45:43 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2009-08-18 21:45:43 +0000
commit8c9427625131a457dc95d114516eddb760a6507a (patch)
treef1b97c83e40b5c007562bc12dbf3a830ed0deb0c /net/nss_ldap
parentca4627a828b3d8500b7282e0590b9c726acde53d (diff)
downloadports-8c9427625131a457dc95d114516eddb760a6507a.tar.gz
ports-8c9427625131a457dc95d114516eddb760a6507a.zip
- fix krb5_ccname broken in previous commit.
PR: 133344
Notes
Notes: svn path=/head/; revision=239896
Diffstat (limited to 'net/nss_ldap')
-rw-r--r--net/nss_ldap/Makefile9
-rw-r--r--net/nss_ldap/files/patch-ldap-nss.c8
2 files changed, 7 insertions, 10 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 17abf6310d29..1c0f6d87ee63 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
@@ -36,6 +36,11 @@ CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
MAN5= nss_ldap.5
+.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_KERBEROS)
+CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-env
+.endif
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
@@ -47,4 +52,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/${MAN5} ${MAN5PREFIX}/man/man5
${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/nss_ldap/files/patch-ldap-nss.c b/net/nss_ldap/files/patch-ldap-nss.c
index 297cc4d403f9..2622dc3b1726 100644
--- a/net/nss_ldap/files/patch-ldap-nss.c
+++ b/net/nss_ldap/files/patch-ldap-nss.c
@@ -9,11 +9,3 @@
#include <sasl/sasl.h>
#elif defined(HAVE_SASL_H)
#include <sasl.h>
-@@ -84,7 +84,7 @@
- #include <gssapi/gssapi.h>
- #include <gssapi/gssapi_krb5.h>
- #endif
--#ifdef CONFIGURE_KRB5_CCNAME
-+#if defined(CONFIGURE_KRB5_CCNAME) && defined(HAVE_KRB5_H)
- #include <krb5.h>
- #endif