aboutsummaryrefslogtreecommitdiff
path: root/net/ntp/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-09-19 20:15:58 +0000
committerCy Schubert <cy@FreeBSD.org>2019-09-19 20:15:58 +0000
commit5425c19fe6f0223eda008832d8485e1ddc3713e4 (patch)
tree199da75a7d3472579ab47685d7738fb08c158962 /net/ntp/Makefile
parentbe67ffd1eb2cf8a2788e6f3badd4e39ab76a6639 (diff)
downloadports-5425c19fe6f0223eda008832d8485e1ddc3713e4.tar.gz
ports-5425c19fe6f0223eda008832d8485e1ddc3713e4.zip
Chase base r352518:
Reduce calls to close(2) at startup through the use of closefrom(2). Submitted by: pawel.biernacki@gmail.com (based on) Obtained from: base r352518
Notes
Notes: svn path=/head/; revision=512372
Diffstat (limited to 'net/ntp/Makefile')
-rw-r--r--net/ntp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index fe585dedb587..eb40a2d5ee27 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -79,6 +79,9 @@ post-extract:
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
@${CHMOD} +x ${WRKSRC}/scripts/build/checkHtmlFileDates
+post-configure:
+ @${ECHO_CMD} '#define HAVE_CLOSEFROM 1' >> ${WRKSRC}/config.h
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}