aboutsummaryrefslogtreecommitdiff
path: root/net/ntp
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-04-15 13:57:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-04-15 13:57:26 +0000
commit3b96446b1131cd92fb79d67f0c00bcdf9ca75b81 (patch)
tree5fc8b62709fc7d833a102afe3c07503e06429ffe /net/ntp
parent140665f4df7c72a4e22bf2d302e6a08acab4433e (diff)
downloadports-3b96446b1131cd92fb79d67f0c00bcdf9ca75b81.tar.gz
ports-3b96446b1131cd92fb79d67f0c00bcdf9ca75b81.zip
maintainer-update:
update ntp port that incorporates latest security fix. PR: 26503 Submitted by: Cy.Schubert@uumail.gov.bc.ca
Notes
Notes: svn path=/head/; revision=41421
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile6
-rw-r--r--net/ntp/distinfo2
-rw-r--r--net/ntp/files/patch-aa38
-rw-r--r--net/ntp/files/patch-ad35
-rw-r--r--net/ntp/files/patch-ntp_control.c44
-rw-r--r--net/ntp/pkg-plist22
6 files changed, 56 insertions, 91 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 84a5278d22ec..80d2c0f6722e 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ntp
-PORTVERSION= 4.0.99k
-PORTREVISION= 2
+PORTVERSION= 4.0.99k23
CATEGORIES= net
-MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/
+MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ \
+ http://www.eeics.udel.edu/~ntp/ntp_spool/ntp4/
MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
diff --git a/net/ntp/distinfo b/net/ntp/distinfo
index 6b782c116eea..d5f19650bd3b 100644
--- a/net/ntp/distinfo
+++ b/net/ntp/distinfo
@@ -1 +1 @@
-MD5 (ntp-4.0.99k.tar.gz) = 6335d5b9b04a2d4670c4eed7300cdb82
+MD5 (ntp-4.0.99k23.tar.gz) = 7b3b73e42f5a10324d06ada4996dccbb
diff --git a/net/ntp/files/patch-aa b/net/ntp/files/patch-aa
new file mode 100644
index 000000000000..2b418488de44
--- /dev/null
+++ b/net/ntp/files/patch-aa
@@ -0,0 +1,38 @@
+--- ntpd/ntp_control.c.orig Mon Apr 9 13:19:56 2001
++++ ntpd/ntp_control.c Wed Apr 11 20:53:28 2001
+@@ -1823,7 +1823,7 @@
+ * Delete leading commas and white space
+ */
+ while (reqpt < reqend && (*reqpt == ',' ||
+- isspace((int)*reqpt)))
++ isspace((unsigned char)*reqpt)))
+ reqpt++;
+ if (reqpt >= reqend)
+ return (0);
+@@ -1846,7 +1846,7 @@
+ tp++;
+ }
+ if ((*tp == '\0') || (*tp == '=')) {
+- while (cp < reqend && isspace((int)*cp))
++ while (cp < reqend && isspace((unsigned char)*cp))
+ cp++;
+ if (cp == reqend || *cp == ',') {
+ buf[0] = '\0';
+@@ -1859,7 +1859,7 @@
+ if (*cp == '=') {
+ cp++;
+ tp = buf;
+- while (cp < reqend && isspace((int)*cp))
++ while (cp < reqend && isspace((unsigned char)*cp))
+ cp++;
+ while (cp < reqend && *cp != ',') {
+ *tp++ = *cp++;
+@@ -1870,7 +1870,7 @@
+ cp++;
+ while (tp > buf) {
+ *tp-- = '\0';
+- if (!isspace((int)(*tp)))
++ if (!isspace((unsigned char)(*tp)))
+ break;
+ }
+ reqpt = cp;
diff --git a/net/ntp/files/patch-ad b/net/ntp/files/patch-ad
deleted file mode 100644
index d6885c485f08..000000000000
--- a/net/ntp/files/patch-ad
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig Sun Feb 27 17:01:04 2000
-+++ configure Tue Mar 7 05:53:20 2000
-@@ -8273,19 +8273,19 @@
- # there is NO way that I can tell to tell if a given OS is using timespec or
- # timeval so just set it here for the one case that is KNOWN to use timespec.
-
--case "$ac_cv_header_timepps_h$ac_cv_header_sys_timepps_h" in
-- *yes*)
-- cat >>confdefs.h <<\EOF
--#define HAVE_PPSAPI 1
--EOF
--
-- ac_cv_var_oncore_ok=yes
-- cat >>confdefs.h <<\EOF
--#define HAVE_TIMESPEC 1
--EOF
--
-- ;;
--esac
-+#case "$ac_cv_header_timepps_h$ac_cv_header_sys_timepps_h" in
-+# *yes*)
-+# cat >>confdefs.h <<\EOF
-+##define HAVE_PPSAPI 1
-+#EOF
-+#
-+# ac_cv_var_oncore_ok=yes
-+# cat >>confdefs.h <<\EOF
-+##define HAVE_TIMESPEC 1
-+#EOF
-+#
-+# ;;
-+#esac
-
- # Check for ioctls TIOCGSERIAL, TIOCSSERIAL, ASYNC_PPS_CD_POS, ASYNC_PPS_CD_NEG
- echo $ac_n "checking for linux/serial.h... $ac_c" 1>&6
diff --git a/net/ntp/files/patch-ntp_control.c b/net/ntp/files/patch-ntp_control.c
deleted file mode 100644
index e93732fb37fc..000000000000
--- a/net/ntp/files/patch-ntp_control.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- ntpd/ntp_control.c.orig Sat Jul 15 10:46:05 2000
-+++ ntpd/ntp_control.c Fri Apr 6 10:41:43 2001
-@@ -1782,7 +1782,7 @@
- * Delete leading commas and white space
- */
- while (reqpt < reqend && (*reqpt == ',' ||
-- isspace((int)*reqpt)))
-+ isspace((unsigned char)*reqpt)))
- reqpt++;
- if (reqpt >= reqend)
- return (0);
-@@ -1805,7 +1805,8 @@
- tp++;
- }
- if ((*tp == '\0') || (*tp == '=')) {
-- while (cp < reqend && isspace((int)*cp))
-+ while (cp < reqend &&
-+ isspace((unsigned char)*cp))
- cp++;
- if (cp == reqend || *cp == ',') {
- buf[0] = '\0';
-@@ -1819,15 +1820,18 @@
- cp++;
- tp = buf;
- while (cp < reqend &&
-- isspace((int)*cp))
-+ isspace((unsigned char)*cp))
- cp++;
-- while (cp < reqend && *cp !=
-- ',')
-+ while (cp < reqend && *cp != ',') {
- *tp++ = *cp++;
-+ if (tp >= buf + sizeof(buf))
-+ return (0);
-+ }
- if (cp < reqend)
- cp++;
- *tp = '\0';
-- while (isspace((int)(*(tp-1))))
-+ while (tp != buf &&
-+ isspace((unsigned char)(*(tp-1))))
- *(--tp) = '\0';
- reqpt = cp;
- *data = buf;
diff --git a/net/ntp/pkg-plist b/net/ntp/pkg-plist
index d0291d3b8543..58a13d1f220c 100644
--- a/net/ntp/pkg-plist
+++ b/net/ntp/pkg-plist
@@ -42,6 +42,8 @@ share/doc/ntp/driver34.htm
share/doc/ntp/driver35.htm
share/doc/ntp/driver36.htm
share/doc/ntp/driver37.htm
+share/doc/ntp/driver38.htm
+share/doc/ntp/driver39.htm
share/doc/ntp/driver4.htm
share/doc/ntp/driver5.htm
share/doc/ntp/driver6.htm
@@ -101,12 +103,10 @@ share/doc/ntp/parsedata.htm
share/doc/ntp/parsenew.htm
share/doc/ntp/patches.htm
share/doc/ntp/pic/9400n.jpg
-share/doc/ntp/pic/alautun4a.gif
share/doc/ntp/pic/alice11.gif
share/doc/ntp/pic/alice12.gif
share/doc/ntp/pic/alice13.gif
share/doc/ntp/pic/alice15.gif
-share/doc/ntp/pic/alice15b.gif
share/doc/ntp/pic/alice23.gif
share/doc/ntp/pic/alice31.gif
share/doc/ntp/pic/alice32.gif
@@ -116,12 +116,16 @@ share/doc/ntp/pic/alice44.gif
share/doc/ntp/pic/alice47.gif
share/doc/ntp/pic/alice51.gif
share/doc/ntp/pic/alice61.gif
-share/doc/ntp/pic/appletree.gif
share/doc/ntp/pic/barnstable.gif
share/doc/ntp/pic/beaver.gif
+share/doc/ntp/pic/boom3.gif
+share/doc/ntp/pic/boom3a.gif
+share/doc/ntp/pic/boom4.gif
+share/doc/ntp/pic/bustardfly.gif
share/doc/ntp/pic/c51.jpg
share/doc/ntp/pic/driver29.gif
share/doc/ntp/pic/fg6021.gif
+share/doc/ntp/pic/fg6039.jpg
share/doc/ntp/pic/flatheads.gif
share/doc/ntp/pic/gadget.jpg
share/doc/ntp/pic/gps167.jpg
@@ -131,21 +135,23 @@ share/doc/ntp/pic/igclock.gif
share/doc/ntp/pic/oncore_evalbig.gif
share/doc/ntp/pic/oncore_remoteant.jpg
share/doc/ntp/pic/oncore_utplusbig.gif
+share/doc/ntp/pic/oz2.gif
share/doc/ntp/pic/panda.gif
share/doc/ntp/pic/pd_om006.gif
share/doc/ntp/pic/pd_om011.gif
share/doc/ntp/pic/pogo.gif
-share/doc/ntp/pic/pogo1.gif
share/doc/ntp/pic/pogo1a.gif
-share/doc/ntp/pic/pogo3.gif
share/doc/ntp/pic/pogo3a.gif
-share/doc/ntp/pic/pogo3b.gif
-share/doc/ntp/pic/pogoa.gif
+share/doc/ntp/pic/pogo4.gif
+share/doc/ntp/pic/pogo5.gif
+share/doc/ntp/pic/pogo6.gif
+share/doc/ntp/pic/pogo8.gif
share/doc/ntp/pic/pzf509.jpg
share/doc/ntp/pic/rabbit.gif
share/doc/ntp/pic/sheepb.jpg
-share/doc/ntp/pic/tardisa.gif
+share/doc/ntp/pic/stack1a.jpg
share/doc/ntp/pic/tonea.gif
+share/doc/ntp/pic/wingdorothy.gif
share/doc/ntp/porting.htm
share/doc/ntp/pps.htm
share/doc/ntp/prefer.htm