aboutsummaryrefslogtreecommitdiff
path: root/net/ntpa
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-12-18 17:09:44 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-12-18 17:09:44 +0000
commitf2758c13ed5319aabbfb0c64bbbf9601b6334f20 (patch)
treec10339d9aafad8608fe9e64733a93fe68b833995 /net/ntpa
parenta063e6b633f830d054a69c8a4c2c04b3175ba94c (diff)
downloadports-f2758c13ed5319aabbfb0c64bbbf9601b6334f20.tar.gz
ports-f2758c13ed5319aabbfb0c64bbbf9601b6334f20.zip
net/ntpa: update 0.7.6 -> 0.7.10
- Lookup on known time servers - Log management with newsyslog - Fixed bug in configuration reload - Fixed bug in URIs with mono 2.6 - Fixed bug in database schema - Trim dist package PR: 215352 Submitted by: Carsten Larsen <cs@innolan.dk> (maintainer)
Notes
Notes: svn path=/head/; revision=428882
Diffstat (limited to 'net/ntpa')
-rw-r--r--net/ntpa/Makefile2
-rw-r--r--net/ntpa/distinfo6
-rw-r--r--net/ntpa/files/ntpa.in2
-rw-r--r--net/ntpa/pkg-deinstall32
-rw-r--r--net/ntpa/pkg-install21
5 files changed, 58 insertions, 5 deletions
diff --git a/net/ntpa/Makefile b/net/ntpa/Makefile
index 2368637448ea..58b4c191dea4 100644
--- a/net/ntpa/Makefile
+++ b/net/ntpa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ntpa
-PORTVERSION= 0.7.6
+PORTVERSION= 0.7.10
CATEGORIES= net
MASTER_SITES= http://dist.innolan.net/
diff --git a/net/ntpa/distinfo b/net/ntpa/distinfo
index 4327963e66f8..7e4eb3834669 100644
--- a/net/ntpa/distinfo
+++ b/net/ntpa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481372685
-SHA256 (ntpa-0.7.6.tar.gz) = 0c24c2640dc78edf8bdcb405df02f81835e6938eb5c4ca2780106091d057bfb5
-SIZE (ntpa-0.7.6.tar.gz) = 3245250
+TIMESTAMP = 1481972002
+SHA256 (ntpa-0.7.10.tar.gz) = 43784b81a98dcbf685fc9ea9b85864a4c06b74bcb148deb6ff67304020821867
+SIZE (ntpa-0.7.10.tar.gz) = 2565305
diff --git a/net/ntpa/files/ntpa.in b/net/ntpa/files/ntpa.in
index 0c477ae2df64..adaba01d0028 100644
--- a/net/ntpa/files/ntpa.in
+++ b/net/ntpa/files/ntpa.in
@@ -93,7 +93,7 @@ ntpa_reload()
_run_rc_notrunning
return 1
else
- echo "Reloading ${name}."
+ echo "Reloading ${name} configuration."
rc_pid=`cat ${pidfile}`
kill -USR1 $rc_pid
fi
diff --git a/net/ntpa/pkg-deinstall b/net/ntpa/pkg-deinstall
new file mode 100644
index 000000000000..9de39eba00f9
--- /dev/null
+++ b/net/ntpa/pkg-deinstall
@@ -0,0 +1,32 @@
+#! /bin/sh
+
+delnewsyslog() {
+ tmp="/etc/#ntpa$$"
+ sed -e '/^\/var\/log\/ntpa\/ntpa.log /d' /etc/newsyslog.conf >${tmp}
+ cat ${tmp} > /etc/newsyslog.conf
+ rm ${tmp}
+}
+
+newsyslog() {
+ ENTRY=`grep /var/log/ntpa/ntpa.log /etc/newsyslog.conf`
+ DEFAULT='/var/log/ntpa/ntpa.log root:ntpa 660 10 * @T00 C /var/run/ntpa/ntpa.pid SIGUSR2'
+ if [ -z "$ENTRY" ]; then
+ exit 0
+ elif [ "$ENTRY" = "$DEFAULT" ]; then
+ delnewsyslog
+ else
+ echo "You have changed the default ntpa entry in \"/etc/newsyslog.conf\"".
+ echo "If you deinstall ntpa permanently, you have to manually remove it"
+ fi
+}
+
+
+case $2 in
+ DEINSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ newsyslog
+ fi
+ ;;
+ POST-DEINSTALL)
+ ;;
+esac
diff --git a/net/ntpa/pkg-install b/net/ntpa/pkg-install
new file mode 100644
index 000000000000..da18ed5f380a
--- /dev/null
+++ b/net/ntpa/pkg-install
@@ -0,0 +1,21 @@
+#! /bin/sh
+
+newsyslog() {
+ if grep -q /var/log/ntpa/ntpa.log /etc/newsyslog.conf; then
+ :
+ else
+ cat >> /etc/newsyslog.conf <<EOT
+/var/log/ntpa/ntpa.log root:ntpa 660 10 * @T00 C /var/run/ntpa/ntpa.pid SIGUSR2
+EOT
+ fi
+}
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ newsyslog
+ fi
+ ;;
+esac