aboutsummaryrefslogtreecommitdiff
path: root/net/obnc/Makefile
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-07-04 01:07:06 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-07-04 01:07:06 +0000
commit40ac86fea46758bb01cfc419e80350ff221a6d32 (patch)
tree5c75d02130ac3ec76ab9e41dbaccfffd63a90e4a /net/obnc/Makefile
parent4f983f06e1cd3d15e7602d0827bffdd3e216b7f0 (diff)
downloadports-40ac86fea46758bb01cfc419e80350ff221a6d32.tar.gz
ports-40ac86fea46758bb01cfc419e80350ff221a6d32.zip
Add Yet Another incarnation of netcat to the ever-growing ports tree.
This one is a rewrite by one of the OpenBSD folks, and features cleaner code and IPv6 support (which neither of the others have).
Notes
Notes: svn path=/head/; revision=44730
Diffstat (limited to 'net/obnc/Makefile')
-rw-r--r--net/obnc/Makefile74
1 files changed, 74 insertions, 0 deletions
diff --git a/net/obnc/Makefile b/net/obnc/Makefile
new file mode 100644
index 000000000000..234821b21d66
--- /dev/null
+++ b/net/obnc/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: obnc
+# Date created: 3 July 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= obnc
+PORTVERSION= 20010703
+CATEGORIES= net ipv6
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+
+MAINTAINER= dd@FreeBSD.org
+
+MANSECTS= 1
+MAN1= nc.1
+MANCOMPRESSED= maybe
+
+# MAN page COMPression SUFFIX
+.if !defined(NOMANCOMPRESS)
+MANCOMPSUFFIX= .gz
+.else
+MANCOMPSUFFIX=
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin/nc
+.for __s in ${MANSECTS}
+.for __m in ${MAN${__s}:S/$/${MANCOMPSUFFIX}/}
+ @${INSTALL_MAN} ${WRKSRC}/${__m} ${PREFIX}/man/man${__s}/${__m}
+.endfor
+.endfor
+
+#
+# Ports build/install stuff stops here. Tarball creation stuff begins here.
+#
+.include <bsd.port.pre.mk>
+CVS_CMD?= cvs -z3
+CVS_DATE= Tue Jul 3 17:56:05 PDT 2001
+CVS_SITES?= anoncvs@anoncvs3.usa.openbsd.org:/cvs \
+ anoncvs@anoncvs1.ca.openbsd.org:/cvs
+CVS_MODULE= src/usr.bin/nc
+
+#
+# CVS checkout stuff mostly stolen from security/openssh-askpass port by
+# kris@freebsd.org
+#
+tarball:
+ @${MKDIR} ${DISTDIR}/${PKGNAME} && \
+ cd ${DISTDIR}/${PKGNAME}; \
+ for CVS_SITE in ${CVS_SITES}; do \
+ ${ECHO_MSG} ">> Attempting to check out from $${CVS_SITE}."; \
+ if ${CVS_CMD} -d $${CVS_SITE} co -D "${CVS_DATE}" \
+ ${CVS_MODULE}; then \
+ cd ${DISTDIR}; \
+ ${ECHO_MSG} ">> Creating dist tarball in ${DISTDIR}"; \
+ ${ECHO_MSG} ">> \"${PKGNAME}.tar.gz\"."; \
+ ${MV} ${PKGNAME}/${CVS_MODULE} \
+ ${PKGNAME}/${CVS_MODULE:H}/${PKGNAME}; \
+ ${TAR} -cz \
+ -X ${FILESDIR}/tarignore \
+ -f ${PKGNAME}.tar.gz \
+ -C ${PKGNAME}/${CVS_MODULE:H} \
+ ${PKGNAME}; \
+ exit; \
+ fi \
+ done; \
+ ${RMDIR} ${DISTDIR}/${PKGNAME}; \
+ ${ECHO_MSG} ">> CVS checkout failed."; \
+ exit 1;
+
+.include <bsd.port.post.mk>