aboutsummaryrefslogtreecommitdiff
path: root/net/opal
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-02 16:25:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-02 16:25:19 +0000
commit2cc5d165ad328ab19689b0d66b55c89a59532535 (patch)
treec44bb278a645abbb5ef3bb12bcb371f265c78bbb /net/opal
parent347bcbe270c56aa919c82cb9bbd5816c642c7f79 (diff)
downloadports-2cc5d165ad328ab19689b0d66b55c89a59532535.tar.gz
ports-2cc5d165ad328ab19689b0d66b55c89a59532535.zip
net/opal: properly set codec-specific options after r468745
Notes
Notes: svn path=/head/; revision=468852
Diffstat (limited to 'net/opal')
-rw-r--r--net/opal/Makefile2
-rw-r--r--net/opal/files/patch-ffmpeg416
2 files changed, 9 insertions, 9 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index ddf47c6fc3bd..a07c6a05a6f1 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opal
PORTVERSION= 3.10.10
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= net
MASTER_SITES= GNOME
diff --git a/net/opal/files/patch-ffmpeg4 b/net/opal/files/patch-ffmpeg4
index ae872bfa8879..1dcb30964de3 100644
--- a/net/opal/files/patch-ffmpeg4
+++ b/net/opal/files/patch-ffmpeg4
@@ -129,8 +129,8 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
// Lagrange multipliers - this is how the context defaults do it:
- m_context->lmin = m_context->qmin * FF_QP2LAMBDA;
- m_context->lmax = m_context->qmax * FF_QP2LAMBDA;
-+ av_opt_set_int(m_context, "lmin", m_context->qmin * FF_QP2LAMBDA, 0);
-+ av_opt_set_int(m_context, "lmax", m_context->qmax * FF_QP2LAMBDA, 0);
++ av_opt_set_int(m_context->priv_data, "lmin", m_context->qmin * FF_QP2LAMBDA, 0);
++ av_opt_set_int(m_context->priv_data, "lmax", m_context->qmax * FF_QP2LAMBDA, 0);
// YUV420P input
m_inputFrame->linesize[0] = m_context->width;
@@ -189,13 +189,13 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
// default is tex^qComp; 1 is constant bitrate
- m_avcontext->rc_eq = (char*) "1";
- //avcontext->rc_eq = "tex^qComp";
-+ av_opt_set(m_avcontext, "rc_eq", (char*) "1", 0);
-+ //av_opt_set(m_avcontext, "rc_eq", "tex^qComp", 0);
++ av_opt_set(m_avcontext->priv_data, "rc_eq", (char*) "1", 0);
++ //av_opt_set(m_avcontext->priv_data, "rc_eq", "tex^qComp", 0);
// These ones technically could be dynamic, I think
m_avcontext->rc_min_rate = 0;
// This is set to 0 in ffmpeg.c, the command-line utility.
- m_avcontext->rc_initial_cplx = 0.0f;
-+ av_opt_set_double(m_avcontext, "rc_init_cplx", 0.0f, 0);
++ av_opt_set_double(m_avcontext->priv_data, "rc_init_cplx", 0.0f, 0);
// And this is set to 1.
// It seems to affect how aggressively the library will raise and lower
@@ -203,7 +203,7 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
// the "vbv buffer", not bits per second, so nobody really knows how
// it works.
- m_avcontext->rc_buffer_aggressivity = 1.0f;
-+ av_opt_set_double(m_avcontext, "rc_buf_aggressivity", 1.0f, 0);
++ av_opt_set_double(m_avcontext->priv_data, "rc_buf_aggressivity", 1.0f, 0);
// Ratecontrol buffer size, in bits. Usually 0.5-1 second worth.
// 224 kbyte is what VLC uses, and it seems to fix the quantization pulse (at Level 5)
@@ -228,8 +228,8 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
// Lagrange multipliers - this is how the context defaults do it:
- m_avcontext->lmin = m_avcontext->qmin * FF_QP2LAMBDA;
- m_avcontext->lmax = m_avcontext->qmax * FF_QP2LAMBDA;
-+ av_opt_set_int(m_avcontext, "lmin", m_avcontext->qmin * FF_QP2LAMBDA, 0);
-+ av_opt_set_int(m_avcontext, "lmax", m_avcontext->qmax * FF_QP2LAMBDA, 0);
++ av_opt_set_int(m_avcontext->priv_data, "lmin", m_avcontext->qmin * FF_QP2LAMBDA, 0);
++ av_opt_set_int(m_avcontext->priv_data, "lmax", m_avcontext->qmax * FF_QP2LAMBDA, 0);
// If framesize has changed or is not yet initialized, fix it up
if((unsigned)m_avcontext->width != m_frameWidth || (unsigned)m_avcontext->height != m_frameHeight) {