aboutsummaryrefslogtreecommitdiff
path: root/net/openmpi/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2015-11-06 01:28:39 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2015-11-06 01:28:39 +0000
commite82140b76b6813ff531730841f013bacdaa73011 (patch)
tree067aa678e45452f706db71c601cc6864f55fb7b7 /net/openmpi/Makefile
parent59841b294c6750097a3a17b3efa1c4bc6148bece (diff)
downloadports-e82140b76b6813ff531730841f013bacdaa73011.tar.gz
ports-e82140b76b6813ff531730841f013bacdaa73011.zip
- Fix plist when the default compiler is gcc5
Spotted by: sunpoet Obtained from: DPorts (marino)
Notes
Notes: svn path=/head/; revision=400879
Diffstat (limited to 'net/openmpi/Makefile')
-rw-r--r--net/openmpi/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 07f4dc1ca908..2404d35a4704 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -31,7 +31,10 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--mandir=${PREFIX}/${MPIDIR}/man \
--program-prefix= \
--with-hwloc=${LOCALBASE} \
- --with-libltdl=${LOCALBASE}
+ --with-libltdl=${LOCALBASE} \
+ --enable-mpi-fortran=usempi \
+ ompi_cv_fortran_ignore_tkr_data=0
+
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= ${PREFIX}/${MPIDIR}/lib \
${PREFIX}/${MPIDIR}/lib/openmpi