aboutsummaryrefslogtreecommitdiff
path: root/net/openmpi3
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-10-16 11:25:29 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-10-16 11:25:29 +0000
commit22d77e41e77b14e787be0268809aad4cdd1bc68f (patch)
tree0990904485433779f53d5a393487a87afefbde0d /net/openmpi3
parenta9b553dae1ea9144c5c32ee7c471711f5b18eee6 (diff)
downloadports-22d77e41e77b14e787be0268809aad4cdd1bc68f.tar.gz
ports-22d77e41e77b14e787be0268809aad4cdd1bc68f.zip
net/openmpi and net/openmpi3: Fix build with GCC 10 and remove deprecated option.
Some gfortran defaults were changed in GCC 10: https://gcc.gnu.org/gcc-10/changes.html The conditional is required because the parameter -fallow-argument-mismatch will break the current default gfortran. Reported by: linimon
Notes
Notes: svn path=/head/; revision=552500
Diffstat (limited to 'net/openmpi3')
-rw-r--r--net/openmpi3/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/openmpi3/Makefile b/net/openmpi3/Makefile
index c433473b6f99..a377652c0048 100644
--- a/net/openmpi3/Makefile
+++ b/net/openmpi3/Makefile
@@ -43,7 +43,6 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--enable-mpi-fortran=usempi \
--enable-mpi-cxx \
--enable-cxx-exceptions \
- --enable-mpi-thread-multiple \
--with-libevent=external \
--enable-mca-no-build=verbs,btl_openib,oob_ud \
--without-verbs \
@@ -93,6 +92,12 @@ SLURM_PLIST_FILES= ${MPIDIR}/lib/openmpi/mca_ess_slurm.la \
${MPIDIR}/share/openmpi/help-plm-slurm.txt \
${MPIDIR}/share/openmpi/help-ras-slurm.txt
+.include <bsd.port.options.mk>
+
+.if ${FORTRAN_DEFAULT} == gfortran && ${GCC_DEFAULT} >= 10
+FCFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/${MPIDIR}/libdata/pkgconfig|g' \
${WRKSRC}/ompi/tools/wrappers/Makefile.am \