aboutsummaryrefslogtreecommitdiff
path: root/net/openntpd/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2017-06-08 20:29:22 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2017-06-08 20:29:22 +0000
commitb9a868dd2334f6a09576873377f1e111bdd196ec (patch)
treeaeadfd7a852fc1b067e9eccd5404cbd1ed58adfe /net/openntpd/Makefile
parent47e6b8a80b870a487b0839b025a629588c0943ed (diff)
downloadports-b9a868dd2334f6a09576873377f1e111bdd196ec.tar.gz
ports-b9a868dd2334f6a09576873377f1e111bdd196ec.zip
Add a periodic script for daily status.
Submitted by: Alexander Milanov <a@amilanov.com>
Notes
Notes: svn path=/head/; revision=442957
Diffstat (limited to 'net/openntpd/Makefile')
-rw-r--r--net/openntpd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 9dc8c7cd5ee5..8a0d50411453 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openntpd
PORTVERSION= 6.0p1
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenNTPD
@@ -23,12 +23,17 @@ USES= ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cacert=${LOCALBASE}/etc/ssl/cert.pem
+SUB_FILES= 480.status-openntpd
+
pre-build:
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/src/ntpd.conf.5 ${WRKSRC}/src/ntpd.8
post-install:
cd ${STAGEDIR}${PREFIX}/etc && ${MV} ntpd.conf ntpd.conf.sample
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${WRKDIR}/480.status-openntpd \
+ ${STAGEDIR}${PREFIX}/etc/periodic/daily
.include <bsd.port.pre.mk>