aboutsummaryrefslogtreecommitdiff
path: root/net/opennx
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-09-16 20:53:49 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-09-16 20:53:49 +0000
commit7a811a41dfa29cd109503cfec5f35c6d1a959270 (patch)
tree0865bc1b1c0fe4b4dfbbab90c94e919d8c3ba251 /net/opennx
parentecf56b60beca146acf0f04c8559e7ae4c303eca6 (diff)
downloadports-7a811a41dfa29cd109503cfec5f35c6d1a959270.tar.gz
ports-7a811a41dfa29cd109503cfec5f35c6d1a959270.zip
New port: net/opennx
OpenNX is an open source drop in replacement for NoMachine's NX client. It is compatible to the original client in that it uses the same syntax for the session configuration files (.nxs files). OpenNX is distributed under the GNU Lesser Public License v2.1. OpenNX is written in C++ and uses the excellent wxWidgets toolkit. PR: ports/159372 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> Approved by: wxs (mentor)
Notes
Notes: svn path=/head/; revision=281859
Diffstat (limited to 'net/opennx')
-rw-r--r--net/opennx/Makefile55
-rw-r--r--net/opennx/distinfo2
-rw-r--r--net/opennx/pkg-descr23
-rw-r--r--net/opennx/pkg-plist69
4 files changed, 149 insertions, 0 deletions
diff --git a/net/opennx/Makefile b/net/opennx/Makefile
new file mode 100644
index 000000000000..9b02b6238417
--- /dev/null
+++ b/net/opennx/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: opennx
+# Date created: Fri 29 Jul 2011
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opennx
+PORTVERSION= 0.16.0.648
+CATEGORIES= net
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/CI-source
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Open source drop in replacement for NoMachine\'s NX client
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= smbclient:${PORTSDIR}/net/samba-libsmbclient \
+ cups:${PORTSDIR}/print/cups-base
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.16
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+USE_WX= 2.8+
+WX_UNICODE= yes
+
+CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+
+MAKE_JOBS_SAFE= yes
+INSTALLS_ICONS= yes
+
+NO_PACKAGE= must generate a fresh private key at install time
+
+SSH_KEYGEN?= /usr/bin/ssh-keygen
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls --localedir=/dev/null
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+# do not use default private key included with tarball
+post-patch:
+ @${RM} ${WRKSRC}/share/keys/server.id_dsa.key
+ @${SSH_KEYGEN} -N '' -b 2048 -q -f ${WRKSRC}/share/keys/server.id_dsa.key
+
+.include <bsd.port.mk>
diff --git a/net/opennx/distinfo b/net/opennx/distinfo
new file mode 100644
index 000000000000..b9b7dc1290cc
--- /dev/null
+++ b/net/opennx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opennx-0.16.0.648.tar.gz) = b8846081e9e8b7fcf936a90df847b348764960e3ee8c1fd06acefae886a13e2b
+SIZE (opennx-0.16.0.648.tar.gz) = 5572559
diff --git a/net/opennx/pkg-descr b/net/opennx/pkg-descr
new file mode 100644
index 000000000000..b3147e3df9c9
--- /dev/null
+++ b/net/opennx/pkg-descr
@@ -0,0 +1,23 @@
+OpenNX is an open source drop in replacement for NoMachine's NX client. It is
+compatible to the original client in that it uses the same syntax for the
+session configuration files (.nxs files). OpenNX is distributed under the GNU
+Lesser Public License v2.1. OpenNX is written in C++ and uses the excellent
+wxWidgets toolkit. Compared to the original client, it also adds some
+additional features which improve usability:
+
+ - Ability to use the OpenSC framework to enable SmartCard based
+ authentication for the initial SSH connection.
+
+ - Ability to use a variety of different proxy types.
+
+ - Ability to fetch session configuration files via http (read only)
+
+ - Ability to disable configuration controls by providing a read only
+ configuration file.
+
+ - Dynamic use of libsmbclient, libcups, libopensc and pulseaudio (no static
+ dependencies).
+
+ - Uses libjpeg-turbo for speed improvement (if available).
+
+WWW: http://opennx.net/
diff --git a/net/opennx/pkg-plist b/net/opennx/pkg-plist
new file mode 100644
index 000000000000..989024964603
--- /dev/null
+++ b/net/opennx/pkg-plist
@@ -0,0 +1,69 @@
+bin/opennx
+bin/pconnect
+bin/watchreader
+share/applnk/xdg/innovidata-opennx-admin.desktop
+share/applnk/xdg/innovidata-opennx-wizard.desktop
+share/applnk/xdg/innovidata-opennx.desktop
+share/applnk/xdg/innovidata-opennx.directory
+share/cups/mime.convs
+share/cups/mime.types
+share/icons/128x128/apps/nx.png
+share/icons/128x128/apps/opennx-admin.png
+share/icons/128x128/apps/opennx-wizard.png
+share/icons/128x128/mimetypes/nx-desktop.png
+share/icons/16x16/apps/nx.png
+share/icons/16x16/apps/opennx-admin.png
+share/icons/16x16/apps/opennx-wizard.png
+share/icons/16x16/mimetypes/nx-desktop.png
+share/icons/256x256/apps/nx.png
+share/icons/256x256/apps/opennx-admin.png
+share/icons/256x256/apps/opennx-wizard.png
+share/icons/256x256/mimetypes/nx-desktop.png
+share/icons/32x32/apps/nx.png
+share/icons/32x32/apps/opennx-admin.png
+share/icons/32x32/apps/opennx-wizard.png
+share/icons/32x32/mimetypes/nx-desktop.png
+share/icons/48x48/apps/nx.png
+share/icons/48x48/apps/opennx-admin.png
+share/icons/48x48/apps/opennx-wizard.png
+share/icons/48x48/mimetypes/nx-desktop.png
+share/icons/512x512/apps/nx.png
+share/icons/512x512/apps/opennx-admin.png
+share/icons/512x512/apps/opennx-wizard.png
+share/icons/512x512/mimetypes/nx-desktop.png
+share/icons/scalable/apps/nx.svg
+share/icons/scalable/apps/opennx-admin.svg
+share/icons/scalable/apps/opennx-wizard.svg
+share/icons/scalable/mimetypes/nx-desktop.svg
+share/keyboards
+share/keys/server.id_dsa.key
+share/keys/server.id_dsa.key.pub
+%%NLS%%share/locale/de/LC_MESSAGES/opennx.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/opennx.mo
+share/pconnect.html
+@dirrm share/keys
+@dirrmtry share/icons/scalable/mimetypes
+@dirrmtry share/icons/scalable/apps
+@dirrmtry share/icons/scalable
+@dirrmtry share/icons/512x512/mimetypes
+@dirrmtry share/icons/512x512/apps
+@dirrmtry share/icons/512x512
+@dirrmtry share/icons/48x48/mimetypes
+@dirrmtry share/icons/48x48/apps
+@dirrmtry share/icons/48x48
+@dirrmtry share/icons/32x32/mimetypes
+@dirrmtry share/icons/32x32/apps
+@dirrmtry share/icons/32x32
+@dirrmtry share/icons/256x256/mimetypes
+@dirrmtry share/icons/256x256/apps
+@dirrmtry share/icons/256x256
+@dirrmtry share/icons/16x16/mimetypes
+@dirrmtry share/icons/16x16/apps
+@dirrmtry share/icons/16x16
+@dirrmtry share/icons/128x128/mimetypes
+@dirrmtry share/icons/128x128/apps
+@dirrmtry share/icons/128x128
+@dirrmtry share/icons
+@dirrmtry share/cups
+@dirrmtry share/applnk/xdg
+@dirrmtry share/applnk