aboutsummaryrefslogtreecommitdiff
path: root/net/openradius/scripts/configure
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 07:29:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 07:29:44 +0000
commit0365ab67fdec4cb55d23c45c9f05c47327d8294f (patch)
treee11ce60b29628599c3a7c06f72fac2c9cf9ce752 /net/openradius/scripts/configure
parent161411524e92d2a16302bb26f694eb258473ade1 (diff)
downloadports-0365ab67fdec4cb55d23c45c9f05c47327d8294f.tar.gz
ports-0365ab67fdec4cb55d23c45c9f05c47327d8294f.zip
New port openradius
A port of OpenRADIUS has not been made yet, though other RADIUS servers are currently in the ports tree. I have found OpenRADIUS to be extremely easy to use, especially for unix password databases. PR: ports/52614 Submitted by: Adam Jette <jettea46@yahoo.com>
Notes
Notes: svn path=/head/; revision=89526
Diffstat (limited to 'net/openradius/scripts/configure')
-rw-r--r--net/openradius/scripts/configure64
1 files changed, 64 insertions, 0 deletions
diff --git a/net/openradius/scripts/configure b/net/openradius/scripts/configure
new file mode 100644
index 000000000000..6ee603c24579
--- /dev/null
+++ b/net/openradius/scripts/configure
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1;
+
+cat > Makefile << END
+
+### Installation paths and compiled-in defaults
+#
+DIR_BIN = $PREFIX/bin
+DIR_SBIN = $PREFIX/sbin
+DIR_ETC = $PREFIX/etc/openradius
+DIR_LIB = $PREFIX/lib/openradius
+FILE_LOG = $PREFIX/var/log/openradius.log
+
+### Modules that will be built and installed
+#
+TGT_LIB += modules/ascfile/ascfile
+TGT_LIB += modules/unixpasswd/unixpasswd
+TGT_LIB += modules/radlogger/radlogger
+TGT_LIB += modules/delay/delay
+TGT_LIB += modules/radsql/radsql
+
+### System compatibility flags, used in some targets' CF_TGT, LF_TGT or LL_TGT
+#
+S_CF_U_INT32_T = -DU_INT32_T=u_int32_t
+S_CF_SYSLOG = -DHAVE_SYSLOG
+S_CF_VSNPRINTF = -DHAVE_VSNPRINTF
+S_CF_SIGACTION = -DHAVE_SIGACTION
+S_LL_INET =
+
+### Build flags for all targets
+#
+CF_ALL = -g -Wall
+LF_ALL =
+LL_ALL =
+
+### Module-specific build flags
+#
+CF_RADLDAP = -I$LDAPINCLUDE/openldap
+LF_RADLDAP = -L$LDAPLIB/usr/local/lib
+LL_RADLDAP = -lldap -llber
+
+### Build tools
+#
+# The C compiler named here must output full (header) dependencies in $(@).d.
+# It may be necessary to create a script similar to ccd-gcc for your compiler.
+#
+CMPLR = ./build/ccd-gcc
+DEFHDR = ./build/hdr
+INST = ./build/install
+ARCH = ar rc \$@ \$^
+#
+COMP = \$(CMPLR) \$(CF_ALL) \$(CF_TGT) -o \$@ -c \$<
+LINK = \$(CMPLR) \$(LF_ALL) \$(LF_TGT) -o \$@ \$^ \$(LL_TGT) \$(LL_ALL)
+COMPLINK = \$(CMPLR) \$(CF_ALL) \$(CF_TGT) \$(LF_ALL) \$(LF_TGT) -o \$@ \$< \$(LL_TGT) \$(LL_ALL)
+
+
+### Standard parts
+#
+include Rules.mk
+
+END
+
+exit 0;