aboutsummaryrefslogtreecommitdiff
path: root/net/p5-AnyMQ-AMQP/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-10-30 11:55:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-10-30 11:55:56 +0000
commita2288cce226c81e0e2b066707f0233d77c0cb5c6 (patch)
treef6a30c29a23f32fc768721bae79e7516ea745fcb /net/p5-AnyMQ-AMQP/Makefile
parentdd4ff5f3e14dd04fb0cc645f51fa4217b5819ee4 (diff)
downloadports-a2288cce226c81e0e2b066707f0233d77c0cb5c6.tar.gz
ports-a2288cce226c81e0e2b066707f0233d77c0cb5c6.zip
AnyMQ::AMQP is AnyMQ trait to work with AMQP servers.
Notes
Notes: svn path=/head/; revision=284709
Diffstat (limited to 'net/p5-AnyMQ-AMQP/Makefile')
-rw-r--r--net/p5-AnyMQ-AMQP/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/p5-AnyMQ-AMQP/Makefile b/net/p5-AnyMQ-AMQP/Makefile
new file mode 100644
index 000000000000..9a543d90c22f
--- /dev/null
+++ b/net/p5-AnyMQ-AMQP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-AnyMQ-AMQP
+# Date created: 2011-10-29
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyMQ-AMQP
+PORTVERSION= 0.30
+CATEGORIES= net devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CLKAO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= AMQP binding for AnyMQ
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-AnyMQ>=0:${PORTSDIR}/devel/p5-AnyMQ \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-AnyEvent-RabbitMQ>=0:${PORTSDIR}/net/p5-AnyEvent-RabbitMQ \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
+
+TEST_DEPENDS= ${RUN_DEPENDS}
+PERL_CONFIGURE= yes
+
+MAN3= AnyMQ::AMQP.3
+
+.if defined(MAINTAINER_MODE)
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} test
+.endif
+
+.include <bsd.port.mk>