aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Filesys-SmbClient/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-10 09:39:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-10 09:39:40 +0000
commit319dd1c84f423bd96cee3bec296d504f1f1c8eda (patch)
treee75d0cb848a03983695da30816156d9b29677980 /net/p5-Filesys-SmbClient/Makefile
parent9f250025a34cf547f6fc6fa9c9b372a8f5c9ea1d (diff)
downloadports-319dd1c84f423bd96cee3bec296d504f1f1c8eda.tar.gz
ports-319dd1c84f423bd96cee3bec296d504f1f1c8eda.zip
add p5-Filesys-SmbClient, an interface for access Samba
filesystem with libsmclient.so
Notes
Notes: svn path=/head/; revision=86709
Diffstat (limited to 'net/p5-Filesys-SmbClient/Makefile')
-rw-r--r--net/p5-Filesys-SmbClient/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/p5-Filesys-SmbClient/Makefile b/net/p5-Filesys-SmbClient/Makefile
new file mode 100644
index 000000000000..76416184b41d
--- /dev/null
+++ b/net/p5-Filesys-SmbClient/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sysutils/p5-Filesys-SmbClient
+# Date created: August 10, 2003
+# Whom: Erwin Lansing <erwin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Filesys-SmbClient
+PORTVERSION= 1.4
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Filesys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@FreeBSD.org
+COMMENT= Interface for access Samba filesystem with libsmclient.so
+
+LIB_DEPENDS= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Filesys::SmbClient.3
+
+post-patch:
+ ${PERL} -pi -e 's!%%LOCALBASE%%!${LOCALBASE}!g' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>