aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-ARP
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 08:50:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 09:00:31 +0000
commitac4bfbc0be40706984164875630fd67339dc3dfe (patch)
tree471d2fdbef2dcc0fe3bf97624201255133a82a16 /net/p5-Net-ARP
parent4607e7e700ca4163983f3d9ec6608936dbbebbf8 (diff)
downloadports-ac4bfbc0be40706984164875630fd67339dc3dfe.tar.gz
ports-ac4bfbc0be40706984164875630fd67339dc3dfe.zip
net/p5-Net-ARP: Update to 1.0.12
Diffstat (limited to 'net/p5-Net-ARP')
-rw-r--r--net/p5-Net-ARP/Makefile4
-rw-r--r--net/p5-Net-ARP/distinfo6
-rw-r--r--net/p5-Net-ARP/files/patch-ppport.h10
-rw-r--r--net/p5-Net-ARP/files/patch-send_packet_bsd.c28
4 files changed, 19 insertions, 29 deletions
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index c33693ac20e6..05271dea9c23 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -1,7 +1,7 @@
# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
PORTNAME= Net-ARP
-PORTVERSION= 1.0.11
+PORTVERSION= 1.0.12
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,7 +13,7 @@ LICENSE= GPLv2
TEST_DEPENDS= p5-Net-Pcap>=0:net/p5-Net-Pcap
-USES= perl5 tar:tgz
+USES= perl5
USE_PERL5= configure
post-install:
diff --git a/net/p5-Net-ARP/distinfo b/net/p5-Net-ARP/distinfo
index c9f1b2b2f082..433abcb5d53a 100644
--- a/net/p5-Net-ARP/distinfo
+++ b/net/p5-Net-ARP/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588777627
-SHA256 (Net-ARP-1.0.11.tgz) = b74feb5c6ca91681ba6faf77c12e351b90b93918c7a9f33c25c1caf75a81090b
-SIZE (Net-ARP-1.0.11.tgz) = 18747
+TIMESTAMP = 1653925928
+SHA256 (Net-ARP-1.0.12.tar.gz) = 28ad8605a3a1e0f868a9898826f5461d80923e6eba1ad5e04737e60e8ba0ec70
+SIZE (Net-ARP-1.0.12.tar.gz) = 16984
diff --git a/net/p5-Net-ARP/files/patch-ppport.h b/net/p5-Net-ARP/files/patch-ppport.h
deleted file mode 100644
index f9ed1ed6981f..000000000000
--- a/net/p5-Net-ARP/files/patch-ppport.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ppport.h.orig 2009-06-20 19:10:51 UTC
-+++ ppport.h
-@@ -211,6 +211,7 @@ __DATA__
- /* Replace: 0 */
- #endif
-
-+#undef PERL_UNUSED_DECL
- #ifdef HASATTRIBUTE
- # if (defined(__GNUC__) && defined(__cplusplus)) || defined(__INTEL_COMPILER)
- # define PERL_UNUSED_DECL
diff --git a/net/p5-Net-ARP/files/patch-send_packet_bsd.c b/net/p5-Net-ARP/files/patch-send_packet_bsd.c
index f724e1f37041..c33169e8c71f 100644
--- a/net/p5-Net-ARP/files/patch-send_packet_bsd.c
+++ b/net/p5-Net-ARP/files/patch-send_packet_bsd.c
@@ -1,17 +1,17 @@
---- send_packet_bsd.c.orig 2009-05-23 11:11:58 UTC
+--- send_packet_bsd.c.orig 2022-05-11 08:27:25 UTC
+++ send_packet_bsd.c
-@@ -56,7 +56,13 @@ int send_packet_bsd(const char *dev, u_c
- flock(bpffd,LOCK_EX);
+@@ -60,7 +60,13 @@ int send_packet_bsd(const char *dev, u_char *packet, u
+ flock(bpffd, LOCK_EX);
- // Bind it to a device
-- ioctl(bpffd,BIOCSETIF,dev);
-+ if (ioctl(bpffd,BIOCSETIF,dev) == -1)
-+ {
-+ flock(bpffd,LOCK_UN);
-+ close(bpffd);
-+ perror("open bpf");
-+ return 0;
-+ }
+ // Bind it to a device
+- ioctl(bpffd, BIOCSETIF, dev);
++ if (ioctl(bpffd, BIOCSETIF, dev) == -1)
++ {
++ flock(bpffd, LOCK_UN);
++ close(bpffd);
++ perror("open bpf");
++ return 0;
++ }
- // Send the packet and unlock
- write(bpffd,packet,packetsize);
+ // Send the packet and unlock
+ write(bpffd, packet, packetsize);