aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Gnats
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-06 04:10:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-06 04:10:40 +0000
commitfb90daf5c1e797848f750023230bcc3640eff87f (patch)
tree8a16c30bf3dbc23d1ae8c3bc3e29afd494843db4 /net/p5-Net-Gnats
parentad58a4d46d03af77eadce1121988a6002e5e719a (diff)
downloadports-fb90daf5c1e797848f750023230bcc3640eff87f.tar.gz
ports-fb90daf5c1e797848f750023230bcc3640eff87f.zip
add p5-Net-Gnats 0.05
Perl interface to GNU Gnats daemon
Notes
Notes: svn path=/head/; revision=108513
Diffstat (limited to 'net/p5-Net-Gnats')
-rw-r--r--net/p5-Net-Gnats/Makefile27
-rw-r--r--net/p5-Net-Gnats/distinfo2
-rw-r--r--net/p5-Net-Gnats/pkg-descr6
-rw-r--r--net/p5-Net-Gnats/pkg-plist12
4 files changed, 47 insertions, 0 deletions
diff --git a/net/p5-Net-Gnats/Makefile b/net/p5-Net-Gnats/Makefile
new file mode 100644
index 000000000000..8cc1403e38b0
--- /dev/null
+++ b/net/p5-Net-Gnats/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: Net-Gnats
+# Date created: May 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Gnats
+PORTVERSION= 0.05
+CATEGORIES= net databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= Net/:cpan \
+ gnatsperl/:sf
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan \
+ ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl interface to GNU Gnats daemon
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Gnats.3 Net::Gnats::PR.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Gnats/distinfo b/net/p5-Net-Gnats/distinfo
new file mode 100644
index 000000000000..5e248bca31c8
--- /dev/null
+++ b/net/p5-Net-Gnats/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Gnats-0.05.tar.gz) = fdf9ab3a0ec3f1ed7a5af90e4e066283
+SIZE (Net-Gnats-0.05.tar.gz) = 9666
diff --git a/net/p5-Net-Gnats/pkg-descr b/net/p5-Net-Gnats/pkg-descr
new file mode 100644
index 000000000000..5231197f2d88
--- /dev/null
+++ b/net/p5-Net-Gnats/pkg-descr
@@ -0,0 +1,6 @@
+Net::Gnats provides a perl interface to the gnatsd command set. Although most
+of the gnatsd command are present and can be explicitly called through
+Net::Gnats, common gnats tasks can be accompished through some methods which
+simplify the process (especially querying the database, editing bugs, etc).
+
+WWW: http://gnatsperl.sourceforge.net/
diff --git a/net/p5-Net-Gnats/pkg-plist b/net/p5-Net-Gnats/pkg-plist
new file mode 100644
index 000000000000..3dc9832bb9c7
--- /dev/null
+++ b/net/p5-Net-Gnats/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Net/Gnats.pm
+%%SITE_PERL%%/Net/Gnats/PR.pm
+%%SITE_PERL%%/auto/Net/Gnats/autosplit.ix
+%%SITE_PERL%%/auto/Net/Gnats/PR/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gnats/.packlist
+@dirrm %%SITE_PERL%%/Net/Gnats
+@dirrm %%SITE_PERL%%/auto/Net/Gnats/PR
+@dirrm %%SITE_PERL%%/auto/Net/Gnats
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gnats
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true