aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-HTTP
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-19 10:52:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-19 10:52:38 +0000
commit0afa95f304354765fdadd97fff1e627cceb4afe7 (patch)
tree2c98a7a6d11613ebc9a2b44b6500805346e9046a /net/p5-Net-HTTP
parentd08f8110ec388dd514b4674d759252b99bc1622c (diff)
downloadports-0afa95f304354765fdadd97fff1e627cceb4afe7.tar.gz
ports-0afa95f304354765fdadd97fff1e627cceb4afe7.zip
- Fix *_DEPENDS
- Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=291805
Diffstat (limited to 'net/p5-Net-HTTP')
-rw-r--r--net/p5-Net-HTTP/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/net/p5-Net-HTTP/Makefile b/net/p5-Net-HTTP/Makefile
index b87815f5aa33..c4ff5bf7dce3 100644
--- a/net/p5-Net-HTTP/Makefile
+++ b/net/p5-Net-HTTP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-HTTP
PORTVERSION= 6.03
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,17 +18,24 @@ COMMENT= Low-level HTTP client
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress \
- p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS= p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL
CONFLICTS= p5-libwww-5*
+PERL_CONFIGURE= yes
+
MAN3= Net::HTTP.3 \
Net::HTTPS.3 \
Net::HTTP::NB.3
-PERL_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+RUN_DEPENDS+= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>