aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-LDAP-Server
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-10-11 07:08:11 +0000
committerWen Heping <wen@FreeBSD.org>2009-10-11 07:08:11 +0000
commit23f12158a027f0e86e6481fb149af1ba68b42ad6 (patch)
treed832d9610a8c4941d956af0cbd0ecacbc8e70e65 /net/p5-Net-LDAP-Server
parenta600d6dbd2c6a27c9c8564d07f210176f7cbc9c6 (diff)
downloadports-23f12158a027f0e86e6481fb149af1ba68b42ad6.tar.gz
ports-23f12158a027f0e86e6481fb149af1ba68b42ad6.zip
Net::LDAP::Server provides the protocol handling for an LDAP
server. You can subclass it and implement the methods you need (see below). Then you just instantiate your subclass and call its handle method to establish a connection with the client. WWW: http://search.cpan.org/dist/Net-LDAP-Server/ Approved by: miwi(mentor)
Notes
Notes: svn path=/head/; revision=242655
Diffstat (limited to 'net/p5-Net-LDAP-Server')
-rw-r--r--net/p5-Net-LDAP-Server/Makefile25
-rw-r--r--net/p5-Net-LDAP-Server/distinfo3
-rw-r--r--net/p5-Net-LDAP-Server/pkg-descr6
-rw-r--r--net/p5-Net-LDAP-Server/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Net-LDAP-Server/Makefile b/net/p5-Net-LDAP-Server/Makefile
new file mode 100644
index 000000000000..744b0e9530e4
--- /dev/null
+++ b/net/p5-Net-LDAP-Server/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-LDAP-Server
+# Date created: 2nd Oct, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-LDAP-Server
+PORTVERSION= 0.42
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl module for LDAP server side protocol handling
+
+BUILD_DEPENDS= p5-Convert-ASN1>=0.22:${PORTSDIR}/converters/p5-Convert-ASN1 \
+ p5-perl-ldap>=0.39:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::LDAP::Server.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-LDAP-Server/distinfo b/net/p5-Net-LDAP-Server/distinfo
new file mode 100644
index 000000000000..9cefd4b591e4
--- /dev/null
+++ b/net/p5-Net-LDAP-Server/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-LDAP-Server-0.42.tar.gz) = cccf0398ef7e582ab08e47cf6c146f19
+SHA256 (Net-LDAP-Server-0.42.tar.gz) = d8499eda048f076ec0f4b0cf0402d2e5abbf4eb14ef277df1162d8b796b1d077
+SIZE (Net-LDAP-Server-0.42.tar.gz) = 6332
diff --git a/net/p5-Net-LDAP-Server/pkg-descr b/net/p5-Net-LDAP-Server/pkg-descr
new file mode 100644
index 000000000000..cefc6fe2bb92
--- /dev/null
+++ b/net/p5-Net-LDAP-Server/pkg-descr
@@ -0,0 +1,6 @@
+Net::LDAP::Server provides the protocol handling for an LDAP
+server. You can subclass it and implement the methods you need
+(see below). Then you just instantiate your subclass and call
+its handle method to establish a connection with the client.
+
+WWW: http://search.cpan.org/dist/Net-LDAP-Server/
diff --git a/net/p5-Net-LDAP-Server/pkg-plist b/net/p5-Net-LDAP-Server/pkg-plist
new file mode 100644
index 000000000000..b1994c906e9a
--- /dev/null
+++ b/net/p5-Net-LDAP-Server/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/LDAP/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/Server/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/LDAP
+@dirrmtry %%SITE_PERL%%/Net