aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OpenID-Consumer
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-29 01:55:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-29 01:55:38 +0000
commit0cf9668ca357539e4628c2f61db97e85f1131c9d (patch)
tree78127cfe2188aedf676c9c3eb937a5c5b5d9778b /net/p5-Net-OpenID-Consumer
parent456a38b6923d2361d283c18149074111c28a8693 (diff)
downloadports-0cf9668ca357539e4628c2f61db97e85f1131c9d.tar.gz
ports-0cf9668ca357539e4628c2f61db97e85f1131c9d.zip
Add p5-Net-OpenID-Consumer 0.13, library for consumers of OpenID
identities. PR: ports/112400 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=192255
Diffstat (limited to 'net/p5-Net-OpenID-Consumer')
-rw-r--r--net/p5-Net-OpenID-Consumer/Makefile30
-rw-r--r--net/p5-Net-OpenID-Consumer/distinfo3
-rw-r--r--net/p5-Net-OpenID-Consumer/pkg-descr5
-rw-r--r--net/p5-Net-OpenID-Consumer/pkg-plist11
4 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-Net-OpenID-Consumer/Makefile b/net/p5-Net-OpenID-Consumer/Makefile
new file mode 100644
index 000000000000..ddfdcd71f388
--- /dev/null
+++ b/net/p5-Net-OpenID-Consumer/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-OpenID-Consumer
+# Date created: 2007-05-04
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenID-Consumer
+PORTVERSION= 0.13
+CATEGORIES= net security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Library for consumers of OpenID identities
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/URI/Fetch.pm:${PORTSDIR}/www/p5-URI-Fetch
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenID::Association.3 Net::OpenID::ClaimedIdentity.3 \
+ Net::OpenID::Consumer.3 Net::OpenID::VerifiedIdentity.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OpenID-Consumer/distinfo b/net/p5-Net-OpenID-Consumer/distinfo
new file mode 100644
index 000000000000..11a574033e59
--- /dev/null
+++ b/net/p5-Net-OpenID-Consumer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-OpenID-Consumer-0.13.tar.gz) = bc8cf68ff0bfd25f085ce8dee8fbf451
+SHA256 (Net-OpenID-Consumer-0.13.tar.gz) = 712a0c00ac72d01156ea593084b50c16f28ae364d60718bc2266d45456306a9a
+SIZE (Net-OpenID-Consumer-0.13.tar.gz) = 17395
diff --git a/net/p5-Net-OpenID-Consumer/pkg-descr b/net/p5-Net-OpenID-Consumer/pkg-descr
new file mode 100644
index 000000000000..2acb56b276ec
--- /dev/null
+++ b/net/p5-Net-OpenID-Consumer/pkg-descr
@@ -0,0 +1,5 @@
+This is the Perl API for (the consumer half of) OpenID, a distributed
+identity system based on proving you own a URL, which is then your
+identity. More information is available at: http://www.danga.com/openid/
+
+WWW: http://search.cpan.org/dist/Net-OpenID-Consumer/
diff --git a/net/p5-Net-OpenID-Consumer/pkg-plist b/net/p5-Net-OpenID-Consumer/pkg-plist
new file mode 100644
index 000000000000..9046c70b7ee9
--- /dev/null
+++ b/net/p5-Net-OpenID-Consumer/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Consumer/.packlist
+%%SITE_PERL%%/Net/OpenID/Association.pm
+%%SITE_PERL%%/Net/OpenID/ClaimedIdentity.pm
+%%SITE_PERL%%/Net/OpenID/Consumer.pm
+%%SITE_PERL%%/Net/OpenID/VerifiedIdentity.pm
+@dirrmtry %%SITE_PERL%%/Net/OpenID
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Consumer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net