aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Traceroute-PurePerl/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-08 06:16:39 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-08 06:16:39 +0000
commitf3c68e0e301ea43e31e5df449161d500693dd309 (patch)
tree4f19f4f020c4458330d6f4cbb454cff066626f12 /net/p5-Net-Traceroute-PurePerl/Makefile
parentcfa207ec25181cb6c8ad10915b37094ed853cb0d (diff)
downloadports-f3c68e0e301ea43e31e5df449161d500693dd309.tar.gz
ports-f3c68e0e301ea43e31e5df449161d500693dd309.zip
Net::Traceroute::PurePerl implements traceroute(1) functionality for
perl5. It allows you to trace the path IP packets take to a destination. It is implemented by using raw sockets to act just like the regular traceroute. You must also be root to use the raw sockets. WWW: http://search.cpan.org/dist/Net-Traceroute-PurePerl PR: ports/145277 Submitted by: Ju Pengfei <jupengfei@gmail.com>
Notes
Notes: svn path=/head/; revision=252433
Diffstat (limited to 'net/p5-Net-Traceroute-PurePerl/Makefile')
-rw-r--r--net/p5-Net-Traceroute-PurePerl/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/p5-Net-Traceroute-PurePerl/Makefile b/net/p5-Net-Traceroute-PurePerl/Makefile
new file mode 100644
index 000000000000..9c4e7e39bbe8
--- /dev/null
+++ b/net/p5-Net-Traceroute-PurePerl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-Traceroute-PurePerl
+# Date created: April 01 2010
+# Whom: jupengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Traceroute-PurePerl
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= Traceroute(1) functionality in perl via raw sockets
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Traceroute.pm:${PORTSDIR}/net/p5-Net-Traceroute
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Net::Traceroute::PurePerl.3
+
+.include <bsd.port.mk>