aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Twitter/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-09-30 02:57:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-09-30 02:57:19 +0000
commit8cc99b9606c3c0cd90dc966fe6669e20c2e4483d (patch)
tree21e3862464d64d461d9c5d721cb57f468303ae92 /net/p5-Net-Twitter/Makefile
parent557d1daffb9518386524d7dc3f78100c377e8397 (diff)
downloadports-8cc99b9606c3c0cd90dc966fe6669e20c2e4483d.tar.gz
ports-8cc99b9606c3c0cd90dc966fe6669e20c2e4483d.zip
- Update to 3.18001
Notes
Notes: svn path=/head/; revision=282649
Diffstat (limited to 'net/p5-Net-Twitter/Makefile')
-rw-r--r--net/p5-Net-Twitter/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/p5-Net-Twitter/Makefile b/net/p5-Net-Twitter/Makefile
index 51904fdfd78b..5f33a570ecb4 100644
--- a/net/p5-Net-Twitter/Makefile
+++ b/net/p5-Net-Twitter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-Twitter
-PORTVERSION= 3.17001
+PORTVERSION= 3.18001
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,6 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to twitter.com
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Data/Visitor/Callback.pm:${PORTSDIR}/devel/p5-Data-Visitor \
${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
@@ -22,7 +25,7 @@ RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/MooseX/Traits.pm:${PORTSDIR}/devel/p5-MooseX-Traits \
${SITE_PERL}/namespace/autoclean.pm:${PORTSDIR}/devel/p5-namespace-autoclean \
${SITE_PERL}/Net/OAuth/Simple.pm:${PORTSDIR}/net/p5-Net-OAuth-Simple \
- ${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any \
+ ${SITE_PERL}/JSON.pm:${PORTSDIR}/converters/p5-JSON \
${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -36,6 +39,7 @@ MAN3= Net::Twitter.3 Net::Twitter::Search.3 Net::Identica.3 \
Net::Twitter::Role::API::REST.3 \
Net::Twitter::Role::API::Search::Trends.3 \
Net::Twitter::Role::API::TwitterVision.3 \
+ Net::Twitter::Role::API::Upload.3 \
Net::Twitter::Role::AutoCursor.3 \
Net::Twitter::Role::InflateObjects.3 \
Net::Twitter::Role::Legacy.3 \