aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Whois/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-06-07 04:07:27 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-06-07 04:07:27 +0000
commitc1decd916568c6c70fa6db772f154d005ec56f96 (patch)
tree52f70da39cf1d411e04ba0393e0bc3089120dc93 /net/p5-Net-Whois/Makefile
parentbacced750ad18aefdb80704c11e98aa37910679b (diff)
downloadports-c1decd916568c6c70fa6db772f154d005ec56f96.tar.gz
ports-c1decd916568c6c70fa6db772f154d005ec56f96.zip
Import of a perl5 module to access the NIC's Whois server
Notes
Notes: svn path=/head/; revision=6784
Diffstat (limited to 'net/p5-Net-Whois/Makefile')
-rw-r--r--net/p5-Net-Whois/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/p5-Net-Whois/Makefile b/net/p5-Net-Whois/Makefile
new file mode 100644
index 000000000000..7a9a247a8c5c
--- /dev/null
+++ b/net/p5-Net-Whois/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-Whois
+# Version required: 0.21
+# Date created: June 7th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= Net-Whois-0.21
+PKGNAME= p5-Net-Whois-0.21
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+
+MANPREFIX= /usr/local/lib/perl5
+MAN3= Net::Whois.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>