aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Client-Twitter/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:26:21 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 00:26:21 +0000
commitaa3c7864e12813a31571eecb2b7fe86be8ec5083 (patch)
tree720d6431c0762e527955b661b39ea2b22978c72c /net/p5-POE-Component-Client-Twitter/Makefile
parent22e5d827b5524afd1b4c9522e851f4816db7c4ab (diff)
downloadports-aa3c7864e12813a31571eecb2b7fe86be8ec5083.tar.gz
ports-aa3c7864e12813a31571eecb2b7fe86be8ec5083.zip
POE::Component::Client::Twitter is a POE component for Twitter API.
WWW: http://search.cpan.org/dist/POE-Component-Client-Twitter/ PR: ports/122716 Submitted by: Masahiro Teramoto <markun at onohara.to>
Notes
Notes: svn path=/head/; revision=211200
Diffstat (limited to 'net/p5-POE-Component-Client-Twitter/Makefile')
-rw-r--r--net/p5-POE-Component-Client-Twitter/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Client-Twitter/Makefile b/net/p5-POE-Component-Client-Twitter/Makefile
new file mode 100644
index 000000000000..7d164581c1f6
--- /dev/null
+++ b/net/p5-POE-Component-Client-Twitter/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-POE-Component-Client-Twitter
+# Date created: 2008-04-13
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Twitter
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= POE chat component for twitter.com
+
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Client-HTTP>=0:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Twitter.3
+
+.include <bsd.port.mk>