aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Server-Twirc
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2009-02-26 11:10:15 +0000
committerLars Thegler <lth@FreeBSD.org>2009-02-26 11:10:15 +0000
commitddf5b4ad8b31b2d1c907b72f27f124e23c50e363 (patch)
tree690302871f77187657154bc0bc12fd564272960e /net/p5-POE-Component-Server-Twirc
parent35c4d0238d3a8cd75755797bb977a25241bf5c16 (diff)
downloadports-ddf5b4ad8b31b2d1c907b72f27f124e23c50e363.tar.gz
ports-ddf5b4ad8b31b2d1c907b72f27f124e23c50e363.zip
Add p5-POE-Component-Server-Twirc 0.06, Twitter/IRC gateway.
Notes
Notes: svn path=/head/; revision=229072
Diffstat (limited to 'net/p5-POE-Component-Server-Twirc')
-rw-r--r--net/p5-POE-Component-Server-Twirc/Makefile43
-rw-r--r--net/p5-POE-Component-Server-Twirc/distinfo3
-rw-r--r--net/p5-POE-Component-Server-Twirc/pkg-descr9
-rw-r--r--net/p5-POE-Component-Server-Twirc/pkg-plist17
4 files changed, 72 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Server-Twirc/Makefile b/net/p5-POE-Component-Server-Twirc/Makefile
new file mode 100644
index 000000000000..0f6a371fb8b9
--- /dev/null
+++ b/net/p5-POE-Component-Server-Twirc/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: net/p5-POE-Component-Server-Twirc
+# Date created: 25 February 2009
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-Twirc
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Twitter/IRC gateway
+
+RUN_DEPENDS= p5-MooseX-POE>=0:${PORTSDIR}/devel/p5-MooseX-POE \
+ p5-Net-Twitter>=1.22:${PORTSDIR}/net/p5-Net-Twitter \
+ p5-Email-Valid>=0:${PORTSDIR}/mail/p5-Email-Valid \
+ p5-POE-Component-Server-IRC>=0.02005:${PORTSDIR}/irc/p5-POE-Component-Server-IRC \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-POE-Component-TSTP>=0:${PORTSDIR}/devel/p5-POE-Component-TSTP \
+ p5-LWP-UserAgent-POE>=0.02:${PORTSDIR}/www/p5-LWP-UserAgent-POE \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Text-Truncate>=0:${PORTSDIR}/textproc/p5-Text-Truncate \
+ p5-MooseX-SimpleConfig>=0:${PORTSDIR}/devel/p5-MooseX-SimpleConfig \
+ p5-MooseX-Getopt>=0.15:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-MooseX-Log-Log4perl>=0:${PORTSDIR}/devel/p5-MooseX-Log-Log4perl \
+ p5-Proc-Daemon>=0:${PORTSDIR}/devel/p5-Proc-Daemon \
+ p5-MooseX-Storage>=0:${PORTSDIR}/devel/p5-MooseX-Storage \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= App::Twirc.3 \
+ App::Twirc::Manual.3 \
+ POE::Component::Server::Twirc.3
+
+post-patch:
+ @${PERL} -pi -e '$$_="" if m/auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Server-Twirc/distinfo b/net/p5-POE-Component-Server-Twirc/distinfo
new file mode 100644
index 000000000000..47ee68e12dda
--- /dev/null
+++ b/net/p5-POE-Component-Server-Twirc/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Server-Twirc-0.06.tar.gz) = 370055d40c068b7a2702c6ac0002a564
+SHA256 (POE-Component-Server-Twirc-0.06.tar.gz) = ba6782bd6e3e0e27eddc91270533ed176a7f1cc13beb96cda52ea179487c38f3
+SIZE (POE-Component-Server-Twirc-0.06.tar.gz) = 37748
diff --git a/net/p5-POE-Component-Server-Twirc/pkg-descr b/net/p5-POE-Component-Server-Twirc/pkg-descr
new file mode 100644
index 000000000000..c99ea499d4ec
--- /dev/null
+++ b/net/p5-POE-Component-Server-Twirc/pkg-descr
@@ -0,0 +1,9 @@
+POE::Component::Server::Twirc provides an IRC/Twitter gateway.
+Twitter friends are added to a channel and messages they post on
+twitter appear as channel messages in IRC. The IRC interface supports
+several Twitter features, including posting status updates, following
+and un-following Twitter feeds, enabling and disabling device
+notifications, sending direct messages, and querying information
+about specific Twitter users.
+
+WWW: http://search.cpan.org/dist/POE-Component-Server-Twirc/
diff --git a/net/p5-POE-Component-Server-Twirc/pkg-plist b/net/p5-POE-Component-Server-Twirc/pkg-plist
new file mode 100644
index 000000000000..a38c33c4e857
--- /dev/null
+++ b/net/p5-POE-Component-Server-Twirc/pkg-plist
@@ -0,0 +1,17 @@
+bin/twirc
+%%SITE_PERL%%/App/Twirc/Manual.pod
+%%SITE_PERL%%/App/Twirc.pm
+%%SITE_PERL%%/POE/Component/Server/Twirc/State.pm
+%%SITE_PERL%%/POE/Component/Server/Twirc/LogAppender.pm
+%%SITE_PERL%%/POE/Component/Server/Twirc.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/Twirc/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/Twirc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/App/Twirc
+@dirrmtry %%SITE_PERL%%/App
+@dirrmtry %%SITE_PERL%%/POE/Component/Server/Twirc
+@dirrmtry %%SITE_PERL%%/POE/Component/Server
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE