aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Rose-URI
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-18 14:02:45 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-18 14:02:45 +0000
commite64dd5e30215e6490c497ebf3c05ee19f62b5893 (patch)
treeb4ea885a827c38fab5c22f1eadf044385325dd9a /net/p5-Rose-URI
parent2c89497bf3ca2a91cf5ecff023171ea9078ff4b7 (diff)
downloadports-e64dd5e30215e6490c497ebf3c05ee19f62b5893.tar.gz
ports-e64dd5e30215e6490c497ebf3c05ee19f62b5893.zip
Rose::URI is an alternative to URI. It provides a rich set of query string
manipulation methods. Query parameters can be added, removed, and checked for their existence. URI allows the entire query to be set or returned as a whole via the query_form or query methods, and the URI::QueryParam module provides a few more methods for query string manipulation. WWW: http://search.cpan.org/dist/Rose-URI/
Notes
Notes: svn path=/head/; revision=264771
Diffstat (limited to 'net/p5-Rose-URI')
-rw-r--r--net/p5-Rose-URI/Makefile25
-rw-r--r--net/p5-Rose-URI/distinfo2
-rw-r--r--net/p5-Rose-URI/pkg-descr7
-rw-r--r--net/p5-Rose-URI/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Rose-URI/Makefile b/net/p5-Rose-URI/Makefile
new file mode 100644
index 000000000000..a320b36cd515
--- /dev/null
+++ b/net/p5-Rose-URI/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Rose-URI
+# Date created: 18 Nov, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-URI
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Easy and efficient manipulation of URI components
+
+RUN_DEPENDS= p5-Rose-Object>=0.854:${PORTSDIR}/devel/p5-Rose-Object \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::URI.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Rose-URI/distinfo b/net/p5-Rose-URI/distinfo
new file mode 100644
index 000000000000..452ce2251fd1
--- /dev/null
+++ b/net/p5-Rose-URI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Rose-URI-1.00.tar.gz) = 4425d60b4cb5355f290ea108ab6e5fbb4cb831857f19010011796793e8b361a3
+SIZE (Rose-URI-1.00.tar.gz) = 9260
diff --git a/net/p5-Rose-URI/pkg-descr b/net/p5-Rose-URI/pkg-descr
new file mode 100644
index 000000000000..944604bf2f75
--- /dev/null
+++ b/net/p5-Rose-URI/pkg-descr
@@ -0,0 +1,7 @@
+Rose::URI is an alternative to URI. It provides a rich set of query string
+manipulation methods. Query parameters can be added, removed, and checked
+for their existence. URI allows the entire query to be set or returned as
+a whole via the query_form or query methods, and the URI::QueryParam module
+provides a few more methods for query string manipulation.
+
+WWW: http://search.cpan.org/dist/Rose-URI/
diff --git a/net/p5-Rose-URI/pkg-plist b/net/p5-Rose-URI/pkg-plist
new file mode 100644
index 000000000000..1a17cf98a654
--- /dev/null
+++ b/net/p5-Rose-URI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Rose/URI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/URI/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose/URI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Rose
+@dirrmtry %%SITE_PERL%%/Rose