aboutsummaryrefslogtreecommitdiff
path: root/net/p5-SOAP-Lite-060
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-05-30 16:32:12 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-05-30 16:32:12 +0000
commit09245cdc7bf5ebaea8e536814b704a62323bccd8 (patch)
tree8888c01eaaf47cb27c4ac59522b5d450c15afb9c /net/p5-SOAP-Lite-060
parentfff9d1d5ebd1cc5f7306d4f66d8c0712c2a60b0a (diff)
downloadports-09245cdc7bf5ebaea8e536814b704a62323bccd8.tar.gz
ports-09245cdc7bf5ebaea8e536814b704a62323bccd8.zip
Existing software might not work with versions of SOAP::Lite newer than
0.60. p5-SOAP-Lite has been updated to CONFLICT with this. (Kids: Don't do SOAP.)
Notes
Notes: svn path=/head/; revision=192401
Diffstat (limited to 'net/p5-SOAP-Lite-060')
-rw-r--r--net/p5-SOAP-Lite-060/Makefile61
-rw-r--r--net/p5-SOAP-Lite-060/distinfo3
-rw-r--r--net/p5-SOAP-Lite-060/files/patch-Makefile.PL10
-rw-r--r--net/p5-SOAP-Lite-060/pkg-descr8
-rw-r--r--net/p5-SOAP-Lite-060/pkg-plist38
5 files changed, 120 insertions, 0 deletions
diff --git a/net/p5-SOAP-Lite-060/Makefile b/net/p5-SOAP-Lite-060/Makefile
new file mode 100644
index 000000000000..80a995abd8ee
--- /dev/null
+++ b/net/p5-SOAP-Lite-060/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: p5-SOAP-Lite
+# Date created: 2007-05-30
+# Whom: lbr
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Lite
+PORTVERSION= 0.60a
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SOAP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= SOAP::Lite - Client and server side SOAP implementation
+
+RUN_DEPENDS= ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+CONFLICTS= p5-SOAP-Lite-0.6[1-9]* p5-SOAP-Lite-0.[7-9]*
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}-060
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.60
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= --noprompt
+INSTALL_TARGET= pure_install
+
+MAN1= SOAPsh.pl.1 XMLRPCsh.pl.1
+MAN3= Apache::SOAP.3 \
+ Apache::XMLRPC::Lite.3 \
+ SOAP::Lite.3 \
+ SOAP::Test.3 \
+ SOAP::Transport::FTP.3 \
+ SOAP::Transport::JABBER.3 \
+ SOAP::Transport::HTTP.3 \
+ SOAP::Transport::IO.3 \
+ SOAP::Transport::LOCAL.3 \
+ SOAP::Transport::MAILTO.3 \
+ SOAP::Transport::MQ.3 \
+ SOAP::Transport::POP3.3 \
+ SOAP::Transport::TCP.3 \
+ UDDI::Lite.3 \
+ XML::Parser::Lite.3 \
+ XMLRPC::Lite.3 \
+ XMLRPC::Test.3 \
+ XMLRPC::Transport::HTTP.3 \
+ XMLRPC::Transport::POP3.3 \
+ XMLRPC::Transport::TCP.3
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's|^#!.*perl|#!${PERL}|' \
+ ${WRKSRC}/bin/* ${WRKSRC}/t/*
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Lite-060/distinfo b/net/p5-SOAP-Lite-060/distinfo
new file mode 100644
index 000000000000..f0fc3c90b6af
--- /dev/null
+++ b/net/p5-SOAP-Lite-060/distinfo
@@ -0,0 +1,3 @@
+MD5 (SOAP-Lite-0.60a.tar.gz) = aed9f8e9c4cf180d15c6e15aedc484d7
+SHA256 (SOAP-Lite-0.60a.tar.gz) = 812b030c10d91f3508c351b41c1af97919c7553dced7534267465082c949cdb8
+SIZE (SOAP-Lite-0.60a.tar.gz) = 170390
diff --git a/net/p5-SOAP-Lite-060/files/patch-Makefile.PL b/net/p5-SOAP-Lite-060/files/patch-Makefile.PL
new file mode 100644
index 000000000000..b5a3dfea5540
--- /dev/null
+++ b/net/p5-SOAP-Lite-060/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Wed Jun 2 12:27:31 2004
++++ Makefile.PL Wed Jun 2 12:28:46 2004
+@@ -67,6 +67,7 @@
+
+ $help and print($helptext), exit;
+
++$prompt and
+ ExtUtils::MakeMaker::prompt(<<EOI . "Press <enter> to see the detailed list.");
+
+ We are about to install SOAP::Lite and for your convenience will provide
diff --git a/net/p5-SOAP-Lite-060/pkg-descr b/net/p5-SOAP-Lite-060/pkg-descr
new file mode 100644
index 000000000000..400937bb0666
--- /dev/null
+++ b/net/p5-SOAP-Lite-060/pkg-descr
@@ -0,0 +1,8 @@
+SOAP::Lite is a collection of Perl modules which provides a
+simple and lightweight interface to the Simple Object Access Protocol
+(SOAP) both on client and server side.
+
+This version is maintained because many systems still require functionality
+in 0.60, which has become broken/deprecated in later versions.
+
+WWW: http://search.cpan.org/dist/SOAP-Lite/
diff --git a/net/p5-SOAP-Lite-060/pkg-plist b/net/p5-SOAP-Lite-060/pkg-plist
new file mode 100644
index 000000000000..6f01639d23b0
--- /dev/null
+++ b/net/p5-SOAP-Lite-060/pkg-plist
@@ -0,0 +1,38 @@
+bin/SOAPsh.pl
+bin/XMLRPCsh.pl
+bin/stubmaker.pl
+%%SITE_PERL%%/Apache/SOAP.pm
+%%SITE_PERL%%/Apache/XMLRPC/Lite.pm
+%%SITE_PERL%%/IO/SessionData.pm
+%%SITE_PERL%%/IO/SessionSet.pm
+%%SITE_PERL%%/SOAP/Lite.pm
+%%SITE_PERL%%/SOAP/Test.pm
+%%SITE_PERL%%/SOAP/Transport/FTP.pm
+%%SITE_PERL%%/SOAP/Transport/HTTP.pm
+%%SITE_PERL%%/SOAP/Transport/IO.pm
+%%SITE_PERL%%/SOAP/Transport/JABBER.pm
+%%SITE_PERL%%/SOAP/Transport/LOCAL.pm
+%%SITE_PERL%%/SOAP/Transport/MAILTO.pm
+%%SITE_PERL%%/SOAP/Transport/MQ.pm
+%%SITE_PERL%%/SOAP/Transport/POP3.pm
+%%SITE_PERL%%/SOAP/Transport/TCP.pm
+%%SITE_PERL%%/UDDI/Lite.pm
+%%SITE_PERL%%/XML/Parser/Lite.pm
+%%SITE_PERL%%/XMLRPC/Lite.pm
+%%SITE_PERL%%/XMLRPC/Test.pm
+%%SITE_PERL%%/XMLRPC/Transport/HTTP.pm
+%%SITE_PERL%%/XMLRPC/Transport/POP3.pm
+%%SITE_PERL%%/XMLRPC/Transport/TCP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Lite/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SOAP
+@dirrm %%SITE_PERL%%/Apache/XMLRPC
+@dirrm %%SITE_PERL%%/SOAP/Transport
+@dirrm %%SITE_PERL%%/UDDI
+@dirrm %%SITE_PERL%%/XMLRPC/Transport
+@dirrm %%SITE_PERL%%/XMLRPC
+@dirrmtry %%SITE_PERL%%/Apache
+@dirrmtry %%SITE_PERL%%/IO
+@dirrmtry %%SITE_PERL%%/SOAP
+@dirrmtry %%SITE_PERL%%/XML/Parser
+@dirrmtry %%SITE_PERL%%/XML