aboutsummaryrefslogtreecommitdiff
path: root/net/p5-XML-Compile-SOAP-WSA
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-27 06:33:26 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-27 06:33:26 +0000
commit585efffeb0aeb052ae4847869b43ad83675de084 (patch)
treec30521dc7b1c64c6f5acffc4971573f28932cad3 /net/p5-XML-Compile-SOAP-WSA
parenta6c4a699fbfe5bdd2e8173d7e7a17b4900af72f1 (diff)
downloadports-585efffeb0aeb052ae4847869b43ad83675de084.tar.gz
ports-585efffeb0aeb052ae4847869b43ad83675de084.zip
The Web Service Addressing protocol is used to select certain service
and port on a SOAP server, just like the "Host" header in "HTTP". The basic SOAP design uses the URI and the "soapAction" header of HTTP (in case it uses HTTP, by far the most often used transport mechanism) However, when the server is hidden behind firewalls and proxies, these fields are rewritten or replaced. This means that the definitions by the WSDL for the client can differ from the configuration of the WWW: http://search.cpan.org/dist/XML-Compile-SOAP-WSA/ PR: ports/152657 Submitted by: Patrick Powell <papowell@astart.com>
Notes
Notes: svn path=/head/; revision=266955
Diffstat (limited to 'net/p5-XML-Compile-SOAP-WSA')
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/Makefile30
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/distinfo2
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/pkg-descr10
-rw-r--r--net/p5-XML-Compile-SOAP-WSA/pkg-plist18
4 files changed, 60 insertions, 0 deletions
diff --git a/net/p5-XML-Compile-SOAP-WSA/Makefile b/net/p5-XML-Compile-SOAP-WSA/Makefile
new file mode 100644
index 000000000000..82a6a9be6c51
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: net/p5-XML-Compile-SOAP-WSA
+# Date created: 23 Nov 2010
+# Whom: Patrick Powell <papowell@astart.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP-WSA
+PORTVERSION= 0.12
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= papowell@astart.com
+COMMENT= SOAP message messages with WSA fields
+
+BUILD_DEPENDS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
+ p5-libwww>=5.803:${PORTSDIR}/www/p5-libwww \
+ p5-Log-Report>=0.22:${PORTSDIR}/devel/p5-Log-Report \
+ p5-XML-Compile-SOAP>=2.10:${PORTSDIR}/net/p5-XML-Compile-SOAP \
+ p5-XML-Compile>=1.01:${PORTSDIR}/textproc/p5-XML-Compile \
+ p5-XML-Compile-Cache>=0.91:${PORTSDIR}/textproc/p5-XML-Compile-Cache
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::SOAP::WSA.3 \
+ XML::Compile::SOAP::WSA::Util.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP-WSA/distinfo b/net/p5-XML-Compile-SOAP-WSA/distinfo
new file mode 100644
index 000000000000..fa3493261974
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XML-Compile-SOAP-WSA-0.12.tar.gz) = 288454b3293672fd78d4834b8cd07d3879ec1487f86c0cbcd6d0f91fe8e54399
+SIZE (XML-Compile-SOAP-WSA-0.12.tar.gz) = 12302
diff --git a/net/p5-XML-Compile-SOAP-WSA/pkg-descr b/net/p5-XML-Compile-SOAP-WSA/pkg-descr
new file mode 100644
index 000000000000..48b685f2fe2f
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/pkg-descr
@@ -0,0 +1,10 @@
+The Web Service Addressing protocol is used to select certain service
+and port on a SOAP server, just like the "Host" header in "HTTP".
+
+The basic SOAP design uses the URI and the "soapAction" header of HTTP
+(in case it uses HTTP, by far the most often used transport mechanism)
+However, when the server is hidden behind firewalls and proxies, these
+fields are rewritten or replaced. This means that the definitions by
+the WSDL for the client can differ from the configuration of the
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP-WSA/
diff --git a/net/p5-XML-Compile-SOAP-WSA/pkg-plist b/net/p5-XML-Compile-SOAP-WSA/pkg-plist
new file mode 100644
index 000000000000..45dd934c7556
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-WSA/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/WSA/.packlist
+%%SITE_PERL%%/XML/Compile/SOAP/WSA.pm
+%%SITE_PERL%%/XML/Compile/SOAP/WSA.pod
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/Util.pm
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/Util.pod
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20060512-wsaw.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20070131-metadata.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20070619-wsa09.xsd
+%%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd/20080723-wsa10.xsd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/WSA/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP/WSA/xsd
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP/WSA
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML