aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Sieve/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /net/pear-Net_Sieve/Makefile
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
downloadports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.tar.gz
ports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=70285
Diffstat (limited to 'net/pear-Net_Sieve/Makefile')
-rw-r--r--net/pear-Net_Sieve/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
new file mode 100644
index 000000000000..1639fa015605
--- /dev/null
+++ b/net/pear-Net_Sieve/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-Net_Sieve
+# Date created: 25 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Sieve
+PORTVERSION= 0.8.1
+CATEGORIES= net www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
+ @${CHOWN} root:wheel ${PEARDIR}/Net/Sieve.php
+ @${CHMOD} a-x ${PEARDIR}/Net/Sieve.php
+
+.include <bsd.port.post.mk>