aboutsummaryrefslogtreecommitdiff
path: root/net/pecl-smbclient/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-03-21 21:59:31 +0000
commit7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8 (patch)
tree2b6d3a0598b45365f230c6f61cf8d8d784b7016d /net/pecl-smbclient/Makefile
parent6b610ab5e04c7e7c7916ffe651ed9b7824436bca (diff)
downloadports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.tar.gz
ports-7cfe69b5842cdb1ef6fbef80bffbc8f2651889a8.zip
- Add USES=samba to handle dependency on samba
Valid ARGS: build, env, lib, run (default: build,run) - Add SAMBA_DEFAULT to bsd.default-versions.mk (default: 4.3) - Remove obsolete samba36 ports - Modify samba4x ports to install libsmbclient - Convert the ports tree to USES=samba Reviewed by: mat Differential Revision: https://reviews.freebsd.org/D8919
Notes
Notes: svn path=/head/; revision=436659
Diffstat (limited to 'net/pecl-smbclient/Makefile')
-rw-r--r--net/pecl-smbclient/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/pecl-smbclient/Makefile b/net/pecl-smbclient/Makefile
index 4f46ad4ef64e..69fec395c311 100644
--- a/net/pecl-smbclient/Makefile
+++ b/net/pecl-smbclient/Makefile
@@ -2,6 +2,7 @@
PORTNAME= smbclient
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -13,10 +14,10 @@ COMMENT= Smbclient wrapper extension
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libsmbclient.so:net/samba-libsmbclient
-
-USES= php:ext tar:tgz
+USES= php:ext samba:lib tar:tgz
CONFIGURE_ARGS= --with-libsmbclient=${LOCALBASE}
+CPPFLAGS+= -I${SAMBAINCLUDES}
+LDFLAGS+= -L${SAMBALIBS}
.include <bsd.port.mk>