aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient/Makefile
diff options
context:
space:
mode:
authorThomas Quinot <thomas@FreeBSD.org>2003-08-14 10:11:01 +0000
committerThomas Quinot <thomas@FreeBSD.org>2003-08-14 10:11:01 +0000
commitb88484ef9d16f65f05481349acc4aee24ff6da8c (patch)
treee2bfaee9e43d93f4b52a33737aeaa1f7eaaed09a /net/pptpclient/Makefile
parentebdc9229acc070e4d2c1708a979ba7a36e4a6462 (diff)
downloadports-b88484ef9d16f65f05481349acc4aee24ff6da8c.tar.gz
ports-b88484ef9d16f65f05481349acc4aee24ff6da8c.zip
Upgrade net/pptpclient to upstream release 1.3.1.
Reviewed by: roberto
Notes
Notes: svn path=/head/; revision=86923
Diffstat (limited to 'net/pptpclient/Makefile')
-rw-r--r--net/pptpclient/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index cd21d9023f68..a59958390c4d 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -6,41 +6,32 @@
#
PORTNAME= pptpclient
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
-DISTNAME= pptp-linux-1.1.0
-DISTFILES= pptp-linux-1.1.0-1.tar.gz
+DISTNAME= pptp-linux-1.3.1
MAINTAINER= thomas@cuivre.fr.eu.org
COMMENT= PPTP client for establishing a VPN link with an NT server
USE_GETOPT_LONG=yes
+MAN8= pptp.8
+
.include <bsd.port.pre.mk>
MAKE_ARGS= DEBUG=""
.if ${OSVERSION} < 500041
MAKE_ARGS+= INCLUDE="${CPPFLAGS}" \
- LIBS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}"
.endif
-GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
-
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @(cd ${WRKDIR} && \
- ${GUNZIP_CMD} ${_DISTDIR}/${DISTFILES} | tar -xf - && \
- ${GUNZIP_CMD} `basename ${DISTFILES} .tar.gz`/${DISTNAME}.tar.gz | \
- tar -xf -)
-
do-install:
- cd ${WRKSRC} ; ${INSTALL_PROGRAM} pptp ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
${MKDIR} ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
+ ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
.include <bsd.port.post.mk>